liboil: don't build examples
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jan 2009 14:49:37 +0000 (14:49 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jan 2009 14:49:37 +0000 (14:49 -0000)
package/liboil/liboil-0.3.15-arm-vfp.patch [new file with mode: 0644]
package/liboil/liboil-vfp.patch [deleted file]
package/liboil/liboil.mk

diff --git a/package/liboil/liboil-0.3.15-arm-vfp.patch b/package/liboil/liboil-0.3.15-arm-vfp.patch
new file mode 100644 (file)
index 0000000..815c9bb
--- /dev/null
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+index 06a0ac9..b8d1640 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -158,7 +158,10 @@ if test x$HAVE_GCC_ASM = xyes -a x$HAVE_POWERPC = xyes ; then
+     true)
+ fi
+-if test x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes ; then
++AC_ARG_ENABLE(vfp,
++  AC_HELP_STRING([--enable-vfp],[compile with Vector Floating-point unit support]),
++  enable_vfp=$enableval,enable_vfp=yes)
++if test "x$enable-vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
+   AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
+     [LIBOIL_CFLAGS="$LIBOIL_CFLAGS -mfpu=vfp"],
+     true)
diff --git a/package/liboil/liboil-vfp.patch b/package/liboil/liboil-vfp.patch
deleted file mode 100644 (file)
index 815c9bb..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 06a0ac9..b8d1640 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -158,7 +158,10 @@ if test x$HAVE_GCC_ASM = xyes -a x$HAVE_POWERPC = xyes ; then
-     true)
- fi
--if test x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes ; then
-+AC_ARG_ENABLE(vfp,
-+  AC_HELP_STRING([--enable-vfp],[compile with Vector Floating-point unit support]),
-+  enable_vfp=$enableval,enable_vfp=yes)
-+if test "x$enable-vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
-   AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
-     [LIBOIL_CFLAGS="$LIBOIL_CFLAGS -mfpu=vfp"],
-     true)
index 3a1c002fea9c1c26c6e47f9565a980559f863e56..2700b22e21f9e07a38081deaa2922e5afb348c26 100644 (file)
@@ -44,12 +44,3 @@ $(LIBOIL_HOOK_POST_INSTALL):
        # Remove useless bugreport program from the target
        rm -f $(TARGET_DIR)/usr/bin/oil-bugreport
        touch $@
-
-
-# Disable some examples that will break the build.
-# There are sveral more that can be removed
-# by someone with time over.
-$(LIBOIL_HOOK_POST_CONFIGURE):
-       $(SED) 's/uberopt//g' $(LIBOIL_DIR)/examples/Makefile
-       $(SED) 's/work//g' $(LIBOIL_DIR)/examples/Makefile
-