e2fsprogs: fix build failure of subst.c
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 12:19:50 +0000 (14:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 12:19:50 +0000 (14:19 +0200)
subst.c is built for the host, but uses defines calculated by the
configure script using the cross-compiler. By passing BUILD_CFLAGS, we
help subst.c include the proper header files, and therefore avoid the
build failure.

Fixes:

  http://autobuild.buildroot.org/results/2a66280800b8aa16fee2701b3f345aa24bb13c35/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/e2fsprogs/e2fsprogs.mk

index c1cbf715a47f6446a42d9e6c62c24e2df6935f6f..63f5856ecd879bc31eec1a30e2e864a8cc617231 100644 (file)
@@ -43,6 +43,12 @@ ifeq ($(BR2_nios2),y)
 E2FSPROGS_CONF_ENV += ac_cv_func_fallocate=no
 endif
 
+# Some programs are built for the host, but use definitions guessed by
+# the configure script (i.e with the cross-compiler). Help them by
+# saying that <sys/stat.h> is available on the host, which is needed
+# for util/subst.c to build properly.
+E2FSPROGS_CONF_ENV += BUILD_CFLAGS="-DHAVE_SYS_STAT_H"
+
 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
 # util-linux libuuid pulls in libintl if needed, so ensure we also
 # link against it, otherwise static linking fails