uboot: Add ELF target
authorSpenser Gilliland <Spenser309@gmail.com>
Wed, 15 May 2013 23:12:02 +0000 (18:12 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Jun 2013 21:24:09 +0000 (23:24 +0200)
adds ELF image option to uboot

Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/uboot/Config.in
boot/uboot/uboot.mk

index a1874a1583350ba58361f118ba4aa8aebd69156b..aadf75707b6d8a918379db9ce169e388585382cc 100644 (file)
@@ -98,6 +98,9 @@ config BR2_TARGET_UBOOT_FORMAT_LDR
        depends on BR2_bfin
        bool "u-boot.ldr"
 
+config BR2_TARGET_UBOOT_FORMAT_ELF
+       bool "u-boot.elf"
+
 endchoice
 
 config BR2_TARGET_UBOOT_OMAP_IFT
index 3e188ee8ab973a5309559a0b21c2e6a5c602d924..b357e0f06b89cbe319e96a18d4a40ce93e39d190 100644 (file)
@@ -26,7 +26,9 @@ UBOOT_SITE    = ftp://ftp.denx.de/pub/u-boot
 UBOOT_SOURCE  = u-boot-$(UBOOT_VERSION).tar.bz2
 endif
 
-ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_ELF),y)
+UBOOT_BIN          = u-boot
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
 UBOOT_BIN          = u-boot.kwb
 UBOOT_MAKE_TARGET  = $(UBOOT_BIN)
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)