Add init script files for snowball board
authorGregory Hermant <gregory.hermant@calao-systems.com>
Fri, 30 Nov 2012 02:39:14 +0000 (02:39 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Nov 2012 16:00:55 +0000 (08:00 -0800)
Signed-off-by: Gregory Hermant <gregory.hermant@calao-systems.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/snowball-init/Config.in [new file with mode: 0644]
package/snowball-init/snowball-init.mk [new file with mode: 0644]

index c369f74ac778ba2c27d67223c3527bbabd039f5d..9c23ae368e0d66c6036a54b3e486130f98e91353 100644 (file)
@@ -554,6 +554,7 @@ source "package/empty/Config.in"
 source "package/googlefontdirectory/Config.in"
 source "package/mobile-broadband-provider-info/Config.in"
 source "package/shared-mime-info/Config.in"
+source "package/snowball-init/Config.in"
 source "package/sound-theme-borealis/Config.in"
 source "package/sound-theme-freedesktop/Config.in"
 endmenu
diff --git a/package/snowball-init/Config.in b/package/snowball-init/Config.in
new file mode 100644 (file)
index 0000000..99abb35
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_SNOWBALL_INIT
+       bool "snowball-init"
+       # Runtime dependency, needed by snowball startup script
+       select BR2_PACKAGE_BLUEZ_UTILS
+       depends on !BR2_avr32
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # dbus, alsa-lib
+       depends on BR2_USE_MMU # dbus
+       select BR2_PACKAGE_UX500_FIRMWARE
+       help
+         Snowball init scripts
+
+         http://www.igloocommunity.org
+
diff --git a/package/snowball-init/snowball-init.mk b/package/snowball-init/snowball-init.mk
new file mode 100644 (file)
index 0000000..278cacb
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# snowball-init
+#
+#############################################################
+SNOWBALL_INIT_VERSION = b064be21de25729039e5e54037bbdd2e25cfd5b7
+SNOWBALL_INIT_SITE = git://igloocommunity.org/git/bsp/snowball-init.git
+SNOWBALL_INIT_LICENSE = BSD-4c
+SNOWBALL_INIT_LICENSE_FILES = debian/copyright
+
+define SNOWBALL_INIT_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/snowball $(TARGET_DIR)/etc/init.d/S50snowball
+endef
+
+$(eval $(generic-package))