package/asterisk: add optional netsnmp dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:42 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index 02d0f2947dfdd3e7a81b372b11097457f23532c5..a6801a006dd9b25c0e4d74ec7e3f0808e21aac6d 100644 (file)
@@ -73,7 +73,6 @@ ASTERISK_CONF_OPTS = \
        --without-mysqlclient \
        --without-nbs \
        --without-neon29 \
-       --without-netsnmp \
        --without-newt \
        --without-openr2 \
        --without-osptk \
@@ -164,6 +163,13 @@ else
 ASTERISK_CONF_OPTS += --without-neon
 endif
 
+ifeq ($(BR2_PACKAGE_NETSNMP),y)
+ASTERISK_DEPENDENCIES += netsnmp
+ASTERISK_CONF_OPTS += --with-netsnmp=$(STAGING_DIR)/usr
+else
+ASTERISK_CONF_OPTS += --without-netsnmp
+endif
+
 ifeq ($(BR2_PACKAGE_LIBOGG),y)
 ASTERISK_DEPENDENCIES += libogg
 ASTERISK_CONF_OPTS += --with-ogg