infra: permissions/users/device tables: avoid adding empty entries
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 22 May 2014 12:35:40 +0000 (14:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 28 May 2014 19:19:45 +0000 (21:19 +0200)
In pkg-generic.mk, an entry would be added to each of the permissions,
devices and users tables, even if FOO_PERMISSIONS/DEVICES/USERS is empty. In
that last case, the entry would contain only the separator, which is
substituted to '\n' in fs/common.mk.
For configurations with many packages, this would render the build output a
bit odd, containing many \n instances (even though the end result in the
target would of course be the same).

This patch cleans up the build output by only adding to these tables when
the package actually specified contents for them.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Tested-by: Romain Naour <romain.naour@openwide.fr>
Acked-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-generic.mk

index 260f37425e93d1f387b8715fa27ce4b8d2b9cb4c..5116ed9fea30dc2153b67a49bbc795474c803d30 100644 (file)
@@ -653,9 +653,16 @@ $$(foreach pkg,$$($(2)_PROVIDES),\
 endif
 
 TARGETS += $(1)
+
+ifneq ($$($(2)_PERMISSIONS),)
 PACKAGES_PERMISSIONS_TABLE += $$($(2)_PERMISSIONS)$$(sep)
+endif
+ifneq ($$($(2)_DEVICES),)
 PACKAGES_DEVICES_TABLE += $$($(2)_DEVICES)$$(sep)
+endif
+ifneq ($$($(2)_USERS),)
 PACKAGES_USERS += $$($(2)_USERS)$$(sep)
+endif
 
 ifeq ($$($(2)_SITE_METHOD),svn)
 DL_TOOLS_DEPENDENCIES += svn