projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8451acf
)
wget: add optional dependency for libidn2
author
Fabrice Fontaine
<fontaine.fabrice@gmail.com>
Tue, 1 May 2018 20:40:34 +0000
(22:40 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Sun, 20 May 2018 14:10:53 +0000
(16:10 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wget/wget.mk
patch
|
blob
|
history
diff --git
a/package/wget/wget.mk
b/package/wget/wget.mk
index 23e4c8accaa20a33c9d5f8a2869c2ba34e5561e5..c3c792f1e847750d26d98327397442aa5f79d5fe 100644
(file)
--- a/
package/wget/wget.mk
+++ b/
package/wget/wget.mk
@@
-26,6
+26,13
@@
else
WGET_CONF_OPTS += --without-ssl
endif
+ifeq ($(BR2_PACKAGE_LIBIDN2),y)
+WGET_CONF_OPTS += --with-libidn
+WGET_DEPENDENCIES += libidn2
+else
+WGET_CONF_OPTS += --without-libidn
+endif
+
ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
WGET_DEPENDENCIES += util-linux
endif