package/netsurf: enable javascript with duktape
authorFrancois Perrad <fperrad@gmail.com>
Wed, 12 Dec 2018 07:14:53 +0000 (08:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 16 Dec 2018 20:33:15 +0000 (21:33 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/netsurf/0003-do-not-cross-compile-nsgenbind.patch [new file with mode: 0644]
package/netsurf/netsurf.mk

diff --git a/package/netsurf/0003-do-not-cross-compile-nsgenbind.patch b/package/netsurf/0003-do-not-cross-compile-nsgenbind.patch
new file mode 100644 (file)
index 0000000..01e77e9
--- /dev/null
@@ -0,0 +1,30 @@
+From 2419ad79b25fcc1746178aba609fddbb0aa8c9e0 Mon Sep 17 00:00:00 2001
+From: Francois Perrad <francois.perrad@gadz.org>
+Date: Sat, 1 Dec 2018 16:10:13 +0100
+Subject: [PATCH] build nsgenbind for the build machine
+
+The nsgenbind tool is meant to be executed on the build machine during
+the build, so it should not be built with the cross-compiler, but with
+the native compiler.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f279f01..5698c87 100644
+--- a/Makefile
++++ b/Makefile
+@@ -109,7 +109,7 @@ endef
+ # prefixed install macro for each host sub target
+ define do_build_prefix_install
+-      $(MAKE) install --directory=$1 HOST=$(BUILD) PREFIX=$(TMP_PREFIX) Q=$(Q) DESTDIR=
++      $(MAKE) install --directory=$1 HOST=$(BUILD) CC=$(BUILD_CC) PREFIX=$(TMP_PREFIX) Q=$(Q) DESTDIR=
+ endef
+-- 
+2.17.1
+
index 23e4de63775b71aeb5681c93916ad0adce292196..004d582562f54e8f949073f1f15bac5d2a5d1d71 100644 (file)
@@ -44,7 +44,6 @@ endef
 endif
 
 define NETSURF_CONFIGURE_CMDS
-       echo "override NETSURF_USE_DUKTAPE := NO"       >  $(@D)/netsurf/Makefile.config
        $(NETSURF_ICONV_CONFIGURE_CMDS)
        $(NETSURF_SVG_CONFIGURE_CMDS)
        $(NETSURF_FONTLIB_CONFIGURE_CMDS)