boost: add option for contract library
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 24 Jun 2018 18:24:43 +0000 (20:24 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 24 Jun 2018 21:54:28 +0000 (23:54 +0200)
Contract library has been added in boost 1.67 and depends on NPTL

Fixes:
 - http://autobuild.buildroot.net/results/a3dd35cfa50a1862c585a648298351c0aba257db

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/boost/Config.in
package/boost/boost.mk

index ec0e19ccb55d05e808a3c825c8b7d0bdf81ac9a2..781bc47c00bd1a1bc8151508b716baaf5096418a 100644 (file)
@@ -77,6 +77,16 @@ config BR2_PACKAGE_BOOST_CONTEXT
        help
          C++11 context switching library.
 
+config BR2_PACKAGE_BOOST_CONTRACT
+       bool "boost-contract"
+       # pthread_condattr_setclock
+       depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
+       help
+         Contract programming for C++.
+
+comment "boost-contract needs a toolchain w/ NPTL"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL
+
 config BR2_PACKAGE_BOOST_COROUTINE
        bool "boost-coroutine"
        depends on BR2_PACKAGE_BOOST_CONTEXT
index 981d701bdf877519fb0b75b28a12e44891d03430..cf0cea7eddeee2694939be2e07be2dbc80f6a06b 100644 (file)
@@ -14,15 +14,16 @@ BOOST_LICENSE_FILES = LICENSE_1_0.txt
 # keep host variant as minimal as possible
 HOST_BOOST_FLAGS = --without-icu --with-toolset=gcc \
        --without-libraries=$(subst $(space),$(comma),atomic chrono context \
-       coroutine date_time exception filesystem graph graph_parallel iostreams \
-       locale log math mpi program_options python random regex serialization \
-       signals system test thread timer type_erasure \
+       contract coroutine date_time exception filesystem graph graph_parallel \
+       iostreams locale log math mpi program_options python random regex \
+       serialization signals system test thread timer type_erasure \
        wave)
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTAINER),,container)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTRACT),,contract)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_COROUTINE),,coroutine)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_EXCEPTION),,exception)