dhcp: add config option for delayed-ack feature of dhcp server
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Fri, 19 Jul 2013 12:46:37 +0000 (14:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 19 Jul 2013 21:39:43 +0000 (23:39 +0200)
This patch creates a config option for the ISC DHCP server to allow passing
--enable-delayed-ack to its configure script.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dhcp/Config.in
package/dhcp/dhcp.mk

index 38cf00796b49ecd44d90f88526b7780a2b25eee4..e341485b1627cf22cf77782516aecfb8959bc571 100644 (file)
@@ -13,6 +13,11 @@ config BR2_PACKAGE_DHCP_SERVER
        help
          DHCP server from the ISC DHCP distribution.
 
+config BR2_PACKAGE_DHCP_SERVER_DELAYED_ACK
+       bool "Enable delayed ACK feature"
+       depends on BR2_PACKAGE_DHCP_SERVER
+       help
+         Enable delayed ACK feature in the ISC DHCP server.
 
 config BR2_PACKAGE_DHCP_RELAY
        bool "dhcp relay"
index ce0cf231da6d80c5abc5e3dd8bf0ae4cd0396ffa..3baeb23842a118c51712334fd8f6185dbf0c86d1 100644 (file)
@@ -17,6 +17,10 @@ DHCP_CONF_OPT = \
        --with-cli-pid-file=/var/run/dhclient.pid \
        --with-relay-pid-file=/var/run/dhcrelay.pid
 
+ifeq ($(BR2_PACKAGE_DHCP_SERVER_DELAYED_ACK),y)
+        DHCP_CONF_OPT += --enable-delayed-ack
+endif
+
 ifneq ($(BR2_INET_IPV6),y)
         DHCP_CONF_OPT += --disable-dhcpv6
 endif