package/gmock: install .pc file
authorYann E. MORIN <yann.morin@orange.com>
Thu, 23 Jun 2016 07:09:34 +0000 (09:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Jun 2016 15:58:46 +0000 (17:58 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin@orange.com>
Signed-off-by: Cedric Chedaleux <cedric.chedaleux@orange.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gmock/gmock.mk
package/gmock/gmock.pc [new file with mode: 0644]

index a0351d0ad6de2f97e99504d832d6b0952add95ab..4f04422a5d00ebf14a7c6112174face45d04cb54 100644 (file)
@@ -39,6 +39,8 @@ define GMOCK_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/lib/.libs/libgmock_main.a $(STAGING_DIR)/usr/lib/libgmock_main.a
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gmock/
        cp -rp $(@D)/include/gmock/* $(STAGING_DIR)/usr/include/gmock/
+       $(INSTALL) -D -m 0755 package/gmock/gmock.pc \
+               $(STAGING_DIR)/usr/lib/pkgconfig/gmock.pc
 endef
 
 # Unzipping inside $(@D) and moving everything from the created subdirectory is
diff --git a/package/gmock/gmock.pc b/package/gmock/gmock.pc
new file mode 100644 (file)
index 0000000..2f90068
--- /dev/null
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${prefix}/lib/
+includedir=${prefix}/include
+
+Name: gmock
+Description: Google C++ Mocking Framework
+Version: 1.7.0
+Libs: -L${libdir} -lgmock
+Libs.private: -lpthread
+Cflags: -I${includedir}