package/nginx: add stream geoip support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 22 Jun 2020 19:31:14 +0000 (21:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 22 Jun 2020 20:44:41 +0000 (22:44 +0200)
stream geoip module has been added in version 1.11.3 with
https://github.com/nginx/nginx/commit/4cf0e2848372b7566f49a9cb4b8dcf9dbad43597

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 09af4680ee51fce5f4660933f6db032acda74533..9f742e3e6bc9f61ecf7c53f9070882802569eebb 100644 (file)
@@ -334,6 +334,12 @@ config BR2_PACKAGE_NGINX_STREAM_SSL_MODULE
        help
          Enable ngx_stream_ssl_module
 
+config BR2_PACKAGE_NGINX_STREAM_GEOIP_MODULE
+       bool "ngx_stream_geoip_module"
+       select BR2_PACKAGE_GEOIP
+       help
+         Enable ngx_stream_geoip_module
+
 config BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE
        bool "ngx_stream_limit_conn_module"
        default y
index 9fdc53fc2a20f8d7243166b20dbbdae9dddd94bd..8a5739cbb456b7c7775d48edfd42ee89cc959f25 100644 (file)
@@ -229,6 +229,11 @@ NGINX_DEPENDENCIES += openssl
 NGINX_CONF_OPTS += --with-stream_ssl_module
 endif
 
+ifeq ($(BR2_PACKAGE_NGINX_STREAM_GEOIP_MODULE),y)
+NGINX_DEPENDENCIES += geoip
+NGINX_CONF_OPTS += --with-stream_geoip_module
+endif
+
 NGINX_CONF_OPTS += \
        $(if $(BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE),,--without-stream_limit_conn_module) \
        $(if $(BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE),,--without-stream_access_module) \