rootfs-ext2: symlink with the compressed rootfs
authorArnout Vandecappelle <arnout@mind.be>
Wed, 6 Nov 2013 23:12:33 +0000 (00:12 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 10 Nov 2013 23:34:14 +0000 (00:34 +0100)
Previously, a symlink was created to the uncompressed filesystem,
which made it a bit useless in case compression was chosen.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/ext2/ext2.mk

index b4280aa5a6c1ea4b2468758e335c819eb79b4cf8..0af955fb6a15c0a4f6196f000540635b67ef9891 100644 (file)
@@ -28,7 +28,7 @@ define ROOTFS_EXT2_CMD
 endef
 
 rootfs-ext2-symlink:
-       ln -sf rootfs.ext2 $(BINARIES_DIR)/rootfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN)
+       ln -sf rootfs.ext2$(ROOTFS_EXT2_COMPRESS_EXT) $(BINARIES_DIR)/rootfs.ext$(BR2_TARGET_ROOTFS_EXT2_GEN)$(ROOTFS_EXT2_COMPRESS_EXT)
 
 ifneq ($(BR2_TARGET_ROOTFS_EXT2_GEN),2)
 ROOTFS_EXT2_POST_TARGETS += rootfs-ext2-symlink