opkg-utils: new package
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 6 Feb 2017 14:57:43 +0000 (15:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 6 Feb 2017 15:07:33 +0000 (16:07 +0100)
Originally, the opkg sources also contained the tools needed to _create_ an
opkg package. In later releases, this code has been split to a separate
package opkg-utils.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/opkg-utils/Config.in.host [new file with mode: 0644]
package/opkg-utils/opkg-utils.hash [new file with mode: 0644]
package/opkg-utils/opkg-utils.mk [new file with mode: 0644]

index 248264195f205f0ff609ad674ef98bed3aa07d23..8da79c303cdd67ad99c6f61ba41f5f32ed3627b2 100644 (file)
@@ -31,6 +31,7 @@ menu "Host utilities"
        source "package/mxsldr/Config.in.host"
        source "package/omap-u-boot-utils/Config.in.host"
        source "package/openocd/Config.in.host"
+       source "package/opkg-utils/Config.in.host"
        source "package/parted/Config.in.host"
        source "package/patchelf/Config.in.host"
        source "package/pru-software-support/Config.in.host"
diff --git a/package/opkg-utils/Config.in.host b/package/opkg-utils/Config.in.host
new file mode 100644 (file)
index 0000000..1c9c474
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_HOST_OPKG_UTILS
+       bool "host opkg-utils"
+       help
+         Helper scripts for use with the opkg package manager.
+
+         https://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/
diff --git a/package/opkg-utils/opkg-utils.hash b/package/opkg-utils/opkg-utils.hash
new file mode 100644 (file)
index 0000000..332823f
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 c14284d999cdd18fee4c6b22720f38beee962b2c8e099166d8d55d76a2111beb  opkg-utils-0.3.4.tar.gz
diff --git a/package/opkg-utils/opkg-utils.mk b/package/opkg-utils/opkg-utils.mk
new file mode 100644 (file)
index 0000000..aa3c44d
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# opkg-utils
+#
+################################################################################
+
+OPKG_UTILS_VERSION = 0.3.4
+OPKG_UTILS_SITE = http://git.yoctoproject.org/git/opkg-utils
+OPKG_UTILS_SITE_METHOD = git
+OPKG_UTILS_LICENSE = GPLv2+
+OPKG_UTILS_LICENSE_FILES = COPYING
+
+define HOST_OPKG_UTILS_BUILD_CMDS
+       $(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS)
+endef
+
+define HOST_OPKG_UTILS_INSTALL_CMDS
+       $(MAKE) -C $(@D) DESTDIR=$(HOST_DIR) PREFIX=/usr install
+endef
+
+$(eval $(host-generic-package))