package: add tinymembench
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 27 Jun 2013 11:55:27 +0000 (13:55 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 27 Jun 2013 11:55:27 +0000 (13:55 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/tinymembench/Config.in [new file with mode: 0644]
package/tinymembench/tinymembench.mk [new file with mode: 0644]

index 0eb6a9cdb1e3b77eaa98529a1e2265f2ebaf671f..81b26be9258e4fcdb48a046951d3f6066165909a 100644 (file)
@@ -44,6 +44,7 @@ source "package/rt-tests/Config.in"
 source "package/strace/Config.in"
 source "package/stress/Config.in"
 source "package/sysprof/Config.in"
+source "package/tinymembench/Config.in"
 source "package/whetstone/Config.in"
 source "package/valgrind/Config.in"
 source "package/pv/Config.in"
diff --git a/package/tinymembench/Config.in b/package/tinymembench/Config.in
new file mode 100644 (file)
index 0000000..0d45532
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_TINYMEMBENCH
+       bool "tinymembench"
+       help
+         Tinymembench is a simple memory benchmark program, which
+         tries to measure the peak bandwidth of sequential memory
+         accesses and the latency of random memory accesses.
+         Bandwidth is measured by running different assembly code for
+         the aligned memory blocks and attempting different prefetch
+         strategies.
+
+         https://github.com/ssvb/tinymembench
diff --git a/package/tinymembench/tinymembench.mk b/package/tinymembench/tinymembench.mk
new file mode 100644 (file)
index 0000000..285d1fd
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# tinymembench
+#
+################################################################################
+
+TINYMEMBENCH_VERSION = v0.2
+TINYMEMBENCH_SITE = http://github.com/ssvb/tinymembench/tarball/$(TINYMEMBENCH_VERSION)
+TINYMEMBENCH_LICENSE = MIT
+TINYMEMBENCH_LICENSE_FILES = main.c
+
+define TINYMEMBENCH_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define TINYMEMBENCH_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0755 -D $(@D)/tinymembench \
+               $(TARGET_DIR)/usr/bin/tinymembench
+endef
+
+$(eval $(generic-package))
+