package/pkg-meson.mk: explicitly specify pkg-config settings
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 5 Feb 2020 10:33:04 +0000 (11:33 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 5 Feb 2020 15:56:43 +0000 (16:56 +0100)
meson is able to distinguish between host (= native) and target (=
cross) compilation. It will explicitly pass different options to
pkg-config to distinguish them. Therefore, we don't need to use the
pkg-config wrapper when using meson, and can instead pass the pkg-config
settings through the cross-compilation.conf.

This is important because in some situations (e.g. for the Python
configuration), meson sets the PKG_CONFIG_LIBDIR variable to a different
value before calling pkg-config. Relying on our wrapper script doesn't
work in that case (except if the script would unconditionally set
PKG_CONFIG_LIBDIR, which it doesn't do at the moment).

Add the sys_root and pkg_config_lib settings to cross-compilation.conf
and use pkgconf directly instead of the wrapper.

Note that this requires us to substitute STAGING_DIR as well, with an
absolute path. This is not a big deal since cross-compilation.conf is
regenerated for every package.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/meson/cross-compilation.conf.in
package/pkg-meson.mk

index fc8e27f7eb2a8ac8bc486b24d84b48abd107d96a..369e225b3e06227696f7ec69cfbeecbc497d42cc 100644 (file)
@@ -8,7 +8,7 @@ c = '@TARGET_CROSS@gcc'
 cpp = '@TARGET_CROSS@g++'
 ar = '@TARGET_CROSS@ar'
 strip = '@TARGET_CROSS@strip'
-pkgconfig = '@HOST_DIR@/usr/bin/pkg-config'
+pkgconfig = '@HOST_DIR@/bin/pkgconf'
 
 [properties]
 needs_exe_wrapper = true
@@ -16,6 +16,8 @@ c_args = [@TARGET_CFLAGS@]
 c_link_args = [@TARGET_LDFLAGS@]
 cpp_args = [@TARGET_CXXFLAGS@]
 cpp_link_args = [@TARGET_LDFLAGS@]
+sys_root = '@STAGING_DIR@'
+pkg_config_libdir = '@STAGING_DIR@/usr/lib/pkgconfig:@STAGING_DIR@/usr/share/pkgconfig'
 
 [host_machine]
 system = 'linux'
index 1f3aaadf5d9ca03241fa05385ab8fcc7a0112ed4..642b7159385bb7807131fe48872ed7daa2b29daf 100644 (file)
@@ -75,6 +75,7 @@ define $(2)_CONFIGURE_CMDS
            -e 's%@TARGET_LDFLAGS@%$$(call make-comma-list,$$($(2)_LDFLAGS))%g' \
            -e 's%@TARGET_CXXFLAGS@%$$(call make-comma-list,$$($(2)_CXXFLAGS))%g' \
            -e 's%@HOST_DIR@%$$(HOST_DIR)%g' \
+           -e 's%@STAGING_DIR@%$$(STAGING_DIR)%g' \
            $$(foreach x,$$($(2)_MESON_EXTRA_BINARIES), \
                -e "/^\[binaries\]$$$$/s:$$$$:\n$$(x):" \
            ) \
@@ -192,6 +193,7 @@ define PKG_MESON_INSTALL_CROSS_CONF
            -e 's%@TARGET_LDFLAGS@%$(call make-comma-list,$(TARGET_LDFLAGS))@PKG_TARGET_CFLAGS@%g' \
            -e 's%@TARGET_CXXFLAGS@%$(call make-comma-list,$(TARGET_CXXFLAGS))@PKG_TARGET_CFLAGS@%g' \
            -e 's%@HOST_DIR@%$(HOST_DIR)%g' \
+           -e 's%@STAGING_DIR@%$$(STAGING_DIR)%g' \
            $(HOST_MESON_PKGDIR)/cross-compilation.conf.in \
            > $(HOST_DIR)/etc/meson/cross-compilation.conf.in
        sed -e 's%@PKG_TARGET_CFLAGS@%%g' \