pv: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 15:07:42 +0000 (17:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:34:03 +0000 (01:34 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pv/Config.in
package/pv/pv.mk

index d7322963c0aaaab11633c1acf7469241a9e2e7b9..671f78e8c9aebabd65d46fd8813fb79e79da1ff2 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_PV
        bool "pv"
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          Pipe Viewer - is a terminal-based tool for
          monitoring the progress of data through a
index 2279805a656d6fd39810a4a4ddc238cf73fc05fd..0ef5a6f6a2f5409eed21974e29dc3c90c2d0d922 100644 (file)
@@ -9,13 +9,7 @@ PV_SOURCE = pv-$(PV_VERSION).tar.bz2
 PV_SITE = http://www.ivarch.com/programs/sources
 PV_LICENSE = Artistic-2.0
 PV_LICENSE_FILES = doc/COPYING
-
-# pv configure script is somewhat stupid: if it cannot find the host
-# gettext tool msgfmt, it concludes that gettext is not available, and
-# provides its own minimal version. Unfortunately, this minimal
-# version conflicts with the available target gettext. We fix this by
-# ensuring that host-gettext is built if gettext support is enabled;
-PV_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext host-gettext)
+PV_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 
 # --relax linker option is enabled by default on sparc/sparc64
 # architectures, and it can't be used together with -r option, so