ffmpeg: depends on host-nasm if MMX is enabled
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 22 Jan 2012 12:04:16 +0000 (13:04 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Jan 2012 22:26:25 +0000 (23:26 +0100)
[Peter: slightly reordered]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/ffmpeg/ffmpeg.mk

index 38f04aafc7df35f7f642576de4f742a6d94d2455..dc572de900cad586875c9cfc9c7e0a370be16716 100644 (file)
@@ -123,9 +123,14 @@ else
 FFMPEG_CONF_OPT += --disable-zlib
 endif
 
+ifeq ($(BR2_i386)$(BR2_x86_64),y)
 # MMX on is default for x86, disable it for lowly x86-type processors
 ifeq ($(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_i686)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
 FFMPEG_CONF_OPT += --disable-mmx
+else
+# If it is enabled, nasm is required
+FFMPEG_DEPENDENCIES += host-nasm
+endif
 endif
 
 # ARM defaults to v5: clear if less, add extra if more