package/bluez-alsa: fix location of alsa config files
authorJörg Krause <joerg.krause@embedded.rocks>
Sat, 1 Feb 2020 10:56:40 +0000 (11:56 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2020 21:48:22 +0000 (22:48 +0100)
Since alsa-lib version 1.1.7 [1] the location for add-on config files
has changed.

In fact, the path for the alsa add-on config files has never been
correct set in the package (it should have been
`/usr/share/alsa/alsa.conf.d`).

With alsa-lib version 1.1.7 or later the correct path is
`/etc/alsa/conf.d`.

[1] https://github.com/alsa-project/alsa-lib/commit/93e03bdc2a3dcd5d12516f5de78e14d88a32ff2c

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bluez-alsa/bluez-alsa.mk

index 6726298f5bbeeab2da3d61318f7a5d7050d6d679..d5cb3ed67bebc107b0f47a1002029001cabc9c24 100644 (file)
@@ -17,7 +17,7 @@ BLUEZ_ALSA_CONF_OPTS = \
        --enable-aplay \
        --disable-debug-time \
        --with-alsaplugindir=/usr/lib/alsa-lib \
-       --with-alsaconfdir=/usr/share/alsa
+       --with-alsaconfdir=/etc/alsa/conf.d
 
 ifeq ($(BR2_PACKAGE_FDK_AAC),y)
 BLUEZ_ALSA_DEPENDENCIES += fdk-aac