toolchain-external: apply kernel headers check to non-custom toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Jun 2014 10:47:38 +0000 (12:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Jun 2014 13:37:23 +0000 (15:37 +0200)
Since the introduction of the kernel headers Config.in options, the
external toolchain logic had a check for custom external toolchains to
verify that the kernel headers version entered by the user matches the
one of the toolchain. However, this check was not made for non-custom
external toolchains (i.e the built-in profiles, such as Linaro,
CodeSourcery and al.), making the assumption that the Buildroot
developers will do the right selection.

However, it is quite nice when bumping external toolchains to have
this automatic kernel headers version check, to ensure we select the
appropriate kernel headers version.

Therefore, this commit makes the kernel headers version check
applicable to non-custom external toolchains.

Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
toolchain/toolchain-external/toolchain-external.mk

index c73cc4ae4d26993821687d5b694dea03df4ef12e..70781db0ff9dcb544b1bde621081c34b4968a7c5 100644 (file)
@@ -466,11 +466,9 @@ define TOOLCHAIN_EXTERNAL_CONFIGURE_CMDS
                @echo "External toolchain doesn't support --sysroot. Cannot use." ; \
                exit 1 ; \
        fi ; \
-       if [ "$(BR2_TOOLCHAIN_EXTERNAL_CUSTOM)" = "y" ]; then \
-               $(call check_kernel_headers_version,\
-                       $(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS)),\
-                       $(call qstrip,$(BR2_TOOLCHAIN_HEADERS_AT_LEAST))); \
-       fi ; \
+       $(call check_kernel_headers_version,\
+               $(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS)),\
+               $(call qstrip,$(BR2_TOOLCHAIN_HEADERS_AT_LEAST))); \
        if test "$(BR2_arm)" = "y" ; then \
                $(call check_arm_abi,\
                        "$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS)",\