xbmc: Fix compile error with missing host-gettext
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 17 Apr 2014 05:26:19 +0000 (07:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Apr 2014 19:52:09 +0000 (21:52 +0200)
autoreconf -vif lib/cpluff
autoreconf: Entering directory `lib/cpluff'
autoreconf: running: autopoint --force
Can't exec "autopoint": No such file or directory at /home/buildroot/output/host/usr/share/autoconf/Autom4te/FileUtils.pm line 345.
autoreconf: failed to run autopoint: No such file or directory
autoreconf: autopoint is needed because this package uses Gettext
make[1]: *** [lib/cpluff/configure] Error 1

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xbmc/xbmc.mk

index 7453db5c9069837c66d1857350204ec18bd68fd9..1bfc17d5f41b0c4e3e56abc060f6b06aa9a1f374 100644 (file)
@@ -129,7 +129,7 @@ endif
 
 # Add HOST_DIR to PATH for codegenerator.mk to find swig
 define XBMC_BOOTSTRAP
-       cd $(@D) && PATH=$(BR_PATH) ./bootstrap
+       cd $(@D) && PATH=$(BR_PATH) AUTOPOINT=/bin/true ./bootstrap
 endef
 XBMC_PRE_CONFIGURE_HOOKS += XBMC_BOOTSTRAP