package/libmicrohttpd: minor fixes and additions
authorCarsten Schoenert <c.schoenert@gmail.com>
Wed, 26 Jun 2013 18:49:40 +0000 (20:49 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 27 Jun 2013 08:32:31 +0000 (10:32 +0200)
Correcting the indentation inside Config.in. Also adding the missed
license information.

Note: libmicrohttpd is partialy dual licensed, if you don't need or want
to use the HTTPS option you can choose between LPGLv2.1+ and the eCos
license (http://ecos.sourceware.org/license-overview.html).
If you use the HTTPS option you have to agree to the LGPLv2.1+!

Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libmicrohttpd/Config.in
package/libmicrohttpd/libmicrohttpd.mk

index 2e4de0f6a99425806c409b2a15a7951bd5d98885..5c20ba602ead83464a205f758e9e396ceca0a621 100644 (file)
@@ -8,13 +8,13 @@ config BR2_PACKAGE_LIBMICROHTTPD
          http://www.gnu.org/software/libmicrohttpd/
 
 config BR2_PACKAGE_LIBMICROHTTPD_SSL
-       bool "https support"
-       depends on BR2_PACKAGE_LIBMICROHTTPD
-       depends on BR2_USE_WCHAR
-       select BR2_PACKAGE_GNUTLS
-       select BR2_PACKAGE_LIBGCRYPT
-       help
-         Enable HTTPS (SSL) support.
+       bool "https support"
+       depends on BR2_PACKAGE_LIBMICROHTTPD
+       depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_GNUTLS
+       select BR2_PACKAGE_LIBGCRYPT
+       help
+         Enable HTTPS (SSL) support.
 
 comment "libmicrohttpd needs a toolchain with thread support"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
index 697cbf50a0f42ab7f65e0be1a6047ef78814b05a..a383667492da2ecb330eeaa9cc9ee87957352e3a 100644 (file)
@@ -6,13 +6,16 @@
 
 LIBMICROHTTPD_VERSION = 0.9.27
 LIBMICROHTTPD_SITE = $(BR2_GNU_MIRROR)/libmicrohttpd
+LIBMICROHTTPD_LICENSE_FILE = COPYING
 LIBMICROHTTPD_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_LIBMICROHTTPD_SSL),y)
+LIBMICROHTTPD_LICENSE = LGPLv2.1+
 LIBMICROHTTPD_DEPENDENCIES += gnutls libgcrypt
 LIBMICROHTTPD_CONF_OPT += --enable-https --with-gnutls=$(STAGING_DIR)/usr \
-                         --with-libgcrypt-prefix=$(STAGING_DIR)/usr
+       --with-libgcrypt-prefix=$(STAGING_DIR)/usr
 else
+LIBMICROHTTPD_LICENSE = LGPLv2.1+ or eCos
 LIBMICROHTTPD_CONF_OPT += --disable-https
 endif