target-gcc: no need to strip binaries, remove .la files and doc
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Jul 2010 16:20:15 +0000 (18:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 27 Jul 2010 16:23:32 +0000 (18:23 +0200)
This is done in a global way by the target-finalize target of the main
Makefile.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gcc/gcc-uclibc-4.x.mk

index 52b20e95916d16a0f04bdb122321a14bbf81cf4c..5dec86c87e7ad195d52989096d1c801b5d7bca55 100644 (file)
@@ -445,15 +445,6 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        # Remove broken specs file (cross compile flag is set).
        rm -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/specs
 
-       -(cd $(TARGET_DIR)/bin && find -type f | xargs $(STRIPCMD) > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/usr/bin && find -type f | xargs $(STRIPCMD) > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR) && $(STRIPCMD) cc1 cc1plus collect2 > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/usr/lib && $(STRIPCMD) libstdc++.so.*.*.* > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/lib && $(STRIPCMD) libgcc_s*.so.*.*.* > /dev/null 2>&1)
-       #
-       rm -f $(TARGET_DIR)/usr/lib/*.la*
-       #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
-       #       $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
        # Work around problem of missing syslimits.h
        if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h ]; then \
                echo "warning: working around missing syslimits.h"; \