package/xbmc: add option to enable libva
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 7 Sep 2014 11:54:35 +0000 (13:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Sep 2014 20:20:38 +0000 (22:20 +0200)
[Thomas: add the comment about the dynamic library dependency.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xbmc/Config.in
package/xbmc/xbmc.mk

index ed0d4ed023b6a0772c5f6ae392f8483fa0f436b8..54f88550105a38e27635855f9fce6f83d2c74143 100644 (file)
@@ -210,6 +210,16 @@ config BR2_PACKAGE_XBMC_LIBUSB
        help
          Enable libusb support.
 
+config BR2_PACKAGE_XBMC_LIBVA
+       bool "va"
+       select BR2_PACKAGE_LIBVA
+       depends on !BR2_PREFER_STATIC_LIB
+       help
+         Enable libva support.
+
+comment "libva support needs toolchain w/ dynamic library"
+       depends on BR2_PREFER_STATIC_LIB
+
 config BR2_PACKAGE_XBMC_WAVPACK
        bool "wavpack"
        select BR2_PACKAGE_WAVPACK
index a38128f8b28dc4a763aa15e89a7ae6127d0d6bf9..87c9d722ef0197d98b742e761eb36d2b06c386b7 100644 (file)
@@ -193,7 +193,7 @@ XBMC_DEPENDENCIES += libtheora
 endif
 
 # xbmc needs libva & libva-glx
-ifeq ($(BR2_PACKAGE_LIBVA)$(BR2_PACKAGE_MESA3D_DRI_DRIVER),yy)
+ifeq ($(BR2_PACKAGE_XBMC_LIBVA)$(BR2_PACKAGE_MESA3D_DRI_DRIVER),yy)
 XBMC_DEPENDENCIES += mesa3d libva
 XBMC_CONF_OPT += --enable-vaapi
 else