package/python3: do not install MS Windows installers on the target
authorTitouan Christophe <titouan.christophe@railnova.eu>
Sat, 12 Sep 2020 11:56:21 +0000 (13:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Sep 2020 13:56:14 +0000 (15:56 +0200)
Buildroot generates Linux systems, so there is no need to have
MS Windows executables in there.

This reduces the target filesystem size by about 2MB:
$ du -hcs usr/lib/python3.8/distutils/command/wininst-*.exe
60K usr/lib/python3.8/distutils/command/wininst-6.0.exe
64K usr/lib/python3.8/distutils/command/wininst-7.1.exe
60K usr/lib/python3.8/distutils/command/wininst-8.0.exe
192K    usr/lib/python3.8/distutils/command/wininst-9.0.exe
220K    usr/lib/python3.8/distutils/command/wininst-9.0-amd64.exe
188K    usr/lib/python3.8/distutils/command/wininst-10.0.exe
220K    usr/lib/python3.8/distutils/command/wininst-10.0-amd64.exe
448K    usr/lib/python3.8/distutils/command/wininst-14.0.exe
576K    usr/lib/python3.8/distutils/command/wininst-14.0-amd64.exe
2,0M    total

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python3/python3.mk

index d63a8bc080236fff53498ae9c12ffd9eac3e9819..017dbd40da4b02cc18e40423540605fc331bf8a9 100644 (file)
@@ -212,6 +212,7 @@ define PYTHON3_REMOVE_USELESS_FILES
        rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON3_VERSION_MAJOR)m-config
        rm -f $(TARGET_DIR)/usr/bin/python3-config
        rm -f $(TARGET_DIR)/usr/bin/smtpd.py.3
+       rm -f $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/distutils/command/wininst*.exe
        for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/config-$(PYTHON3_VERSION_MAJOR)m-*/ \
                -type f -not -name Makefile` ; do \
                rm -f $$i ; \