rng-tools: bump to version 5
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 26 Nov 2014 19:01:18 +0000 (16:01 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Nov 2014 21:27:18 +0000 (22:27 +0100)
Add semi-automatic libgcrypt dependency for i386/x86_64 to use RDRAND.
This is exclusively used by rngd for which we don't yet ship an
initscript/service file. Even so the user can choose to disable it at
invocation time via the --no-drng option (which must be accounted for).

Also add hash file.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rng-tools/Config.in
package/rng-tools/rng-tools.hash [new file with mode: 0644]
package/rng-tools/rng-tools.mk

index c50a8c084ab818f190031e586beb254328a6123d..43c5a1c2e5b9454991f928d72d6ca466ca381d90 100644 (file)
@@ -1,6 +1,8 @@
 config BR2_PACKAGE_RNG_TOOLS
        bool "rng-tools"
        select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+       # For rdrand ligcrypt is required and it's not obvious to users
+       select BR2_PACKAGE_LIBGCRYPT if BR2_i386 || BR2_x86_64
        help
          Daemon to use hardware random number generators.
 
diff --git a/package/rng-tools/rng-tools.hash b/package/rng-tools/rng-tools.hash
new file mode 100644 (file)
index 0000000..09769e4
--- /dev/null
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/gkernel/files/rng-tools/5/
+md5    6726cdc6fae1f5122463f24ae980dd68        rng-tools-5.tar.gz
+sha1   3092768ac45315a5dcc0170d05566d1d00dbad96        rng-tools-5.tar.gz
index 56858e7ead89214171915053c737b7dcdfc30e43..5b89656e02b26af84e8ef59ac9d70cc7331588a6 100644 (file)
@@ -4,13 +4,21 @@
 #
 ################################################################################
 
-RNG_TOOLS_VERSION = 4
+RNG_TOOLS_VERSION = 5
 RNG_TOOLS_SITE = http://downloads.sourceforge.net/project/gkernel/rng-tools/$(RNG_TOOLS_VERSION)
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
-RNG_TOOLS_CONF_ENV = LIBS="-largp"
-RNG_TOOLS_DEPENDENCIES = argp-standalone
-endif
 RNG_TOOLS_LICENSE = GPLv2
 RNG_TOOLS_LICENSE_FILES = COPYING
 
+# Work around for uClibc's lack of argp_*() functions
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+RNG_TOOLS_CONF_ENV += LIBS="-largp"
+RNG_TOOLS_DEPENDENCIES += argp-standalone
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+RNG_TOOLS_DEPENDENCIES += libgcrypt
+else
+RNG_TOOLS_CONF_OPTS += --without-libgcrypt
+endif
+
 $(eval $(autotools-package))