iwd: fix dbus build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 12 Dec 2018 20:13:08 +0000 (21:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 20:22:05 +0000 (21:22 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

iwd uses the datadir variable from dbus-1.pc to decide where to install
things. Since DESTDIR is prepended to the install destination, this will
end up in the wrong location.

Until a better solution is found in pkgconf, pass the usbdropdir to use
explicitly instead of relying on dbus-1.pc.

Fixes:
 - http://autobuild.buildroot.org/results/2b9e28264248f073cc9973bd4c7a89363ec9c0c3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/iwd/iwd.mk

index 2ff8f88cf8a9fe2603e5186bb86ea2292fff1502..1cfc05be41a3d761c0fa3e022b37cb7f674f6c80 100644 (file)
@@ -22,7 +22,7 @@ endef
 IWD_POST_PATCH_HOOKS += IWD_MKDIR_BUILD_AUX
 
 ifeq ($(BR2_PACKAGE_DBUS),y)
-IWD_CONF_OPTS += --enable-dbus-policy
+IWD_CONF_OPTS += --enable-dbus-policy --with-dbus-datadir=/usr/share
 IWD_DEPENDENCIES += dbus
 else
 IWD_CONF_OPTS += --disable-dbus-policy