package/scrub: new package
authorSamuel Martin <s.martin49@gmail.com>
Mon, 7 Mar 2016 21:06:46 +0000 (22:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Mar 2016 20:08:43 +0000 (21:08 +0100)
Fetch a patch fixing autoreconf call.
Patch already sent and merged upstream.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Cc: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/scrub/Config.in [new file with mode: 0644]
package/scrub/scrub.hash [new file with mode: 0644]
package/scrub/scrub.mk [new file with mode: 0644]

index c4d98c432f1ac586b290f66b64cc8f5ac2dd3576..d916154891e7779afbb603e10fe649784ef20d06 100644 (file)
@@ -1636,6 +1636,7 @@ endif
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        source "package/rsyslog/Config.in"
 endif
+       source "package/scrub/Config.in"
        source "package/scrypt/Config.in"
        source "package/smack/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
diff --git a/package/scrub/Config.in b/package/scrub/Config.in
new file mode 100644 (file)
index 0000000..84bcc29
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_SCRUB
+       bool "scrub"
+       help
+         Scrub iteratively writes patterns on files or disk devices
+         to make retrieving the data more difficult.
+
+         https://github.com/chaos/scrub/
diff --git a/package/scrub/scrub.hash b/package/scrub/scrub.hash
new file mode 100644 (file)
index 0000000..0041fd0
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  838b061b2e1932b342fb9695c5579cdff5d2d72506cb41d6d8032eba18aed969  scrub-2.6.1.tar.gz
+sha256  6a129b4e0df6ebe02d449fa481db7b75be5eff08ce518aa77edd74c6b17c5ae4  11d30916dd9c11a26c7c8a0f6db9e6ebca301594.patch
diff --git a/package/scrub/scrub.mk b/package/scrub/scrub.mk
new file mode 100644 (file)
index 0000000..b816272
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# scrub
+#
+################################################################################
+
+SCRUB_VERSION = 2.6.1
+SCRUB_SITE = $(call github,chaos,scrub,$(SCRUB_VERSION))
+SCRUB_LICENSE = GPLv2+
+SCRUB_LICENSE_FILES = COPYING DISCLAIMER
+SCRUB_PATCH = https://github.com/chaos/scrub/commit/11d30916dd9c11a26c7c8a0f6db9e6ebca301594.patch
+
+# Fetching from the git repo, no configure/Makefile generated, and patching
+# configure.ac
+SCRUB_AUTORECONF = YES
+
+$(eval $(autotools-package))