'source' target should depend on 'dirs'
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Wed, 27 Jul 2011 09:34:51 +0000 (11:34 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Aug 2011 19:44:56 +0000 (21:44 +0200)
In the following command flow:
make distclean
make <board>_defconfig
make source

the dl directory would normally be created by the first wget download. If there are no such downloads, e.g. because you use a local download mirror (e.g. scp, file) or only use git/svn/hg/bzr repositories, the dl directory is not created automatically. This causes e.g. the 'pushd' command in the respective _DOWNLOAD commands to fail.

This patch adds a dependency to the 'dirs' target to 'source', fixing this scenario.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 02a16599911cdc676b6d988a09ad26db4fb107d2..df6ce8f534ef056c6740f7b75c2207aba531e29e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -486,7 +486,7 @@ target-purgelocales:
        done
 endif
 
-source: $(TARGETS_SOURCE) $(HOST_SOURCE)
+source: dirs $(TARGETS_SOURCE) $(HOST_SOURCE)
 
 external-deps:
        @$(MAKE) -Bs DL_MODE=SHOW_EXTERNAL_DEPS $(EXTRAMAKEARGS) source | sort -u