pv: fix build error on sparc/sparc64
authorSergio Prado <sergio.prado@e-labworks.com>
Tue, 5 Jan 2016 21:01:48 +0000 (19:01 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Jan 2016 21:40:27 +0000 (22:40 +0100)
Relax linker option is enabled by default on sparc/sparc64
architectures, and it can't be used together with -r option, so disable
it.

Fixes:
http://autobuild.buildroot.net/results/fadc6fc5500d68b91aead58b1d74887db5244f52/
http://autobuild.buildroot.net/results/2f30486f2d72e0277fc30febd4012825a59e4f41/
http://autobuild.buildroot.net/results/82ccb8f0818d1909309eaef969548f963fc6cf04/
...

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pv/pv.mk

index 5346b10fc49f6215fad9a20ad3a4bec7359fc71c..47f570f8be69c54a238be4287eae24ea88de17c3 100644 (file)
@@ -17,6 +17,13 @@ PV_LICENSE_FILES = doc/COPYING
 # ensuring that host-gettext is built if gettext support is enabled;
 PV_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext host-gettext)
 
+# --relax linker option is enabled by default on sparc/sparc64
+# architectures, and it can't be used together with -r option, so
+# disable it.
+ifeq ($(BR2_sparc)$(BR2_sparc64),y)
+PV_LDFLAGS = "-Wl,--no-relax"
+endif
+
 # While 'pv' uses autoconf, it does not use automake for its
 # makefiles. It uses $(LD) $(LDFLAGS) to achieve partial linking, but
 # using 'ld' directly doesn't work well with some toolchain
@@ -25,6 +32,6 @@ PV_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext host-gettext)
 # ensure that 'gcc' is used to do these partial linking steps.
 PV_MAKE_OPTS = \
        LD="$(TARGET_CC)" \
-       LDFLAGS="-Wl,-r -nostdlib"
+       LDFLAGS="-Wl,-r -nostdlib $(PV_LDFLAGS)"
 
 $(eval $(autotools-package))