busybox: bump to version 1.25.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 10 Oct 2016 17:14:03 +0000 (14:14 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 11 Oct 2016 10:17:27 +0000 (12:17 +0200)
Drop upstream patches.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/0003-gzip.patch [deleted file]
package/busybox/0003-top-move-free-prev_hist-out-of-signal-path.patch [new file with mode: 0644]
package/busybox/0004-ip.patch [deleted file]
package/busybox/0005-ntpd.patch [deleted file]
package/busybox/0006-top-move-free-prev_hist-out-of-signal-path.patch [deleted file]
package/busybox/busybox.hash
package/busybox/busybox.mk

diff --git a/package/busybox/0003-gzip.patch b/package/busybox/0003-gzip.patch
deleted file mode 100644 (file)
index f9b321f..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-From upstream: https://busybox.net/downloads/fixes-1.25.0/
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
---- busybox-1.25.0/archival/gzip.c
-+++ busybox-1.25.0-gzip/archival/gzip.c
-@@ -2220,10 +2220,7 @@ int gzip_main(int argc UNUSED_PARAM, cha
-       opt >>= ENABLE_GUNZIP ? 7 : 5; /* drop cfv[dt]qn bits */
-       if (opt == 0)
-               opt = 1 << 6; /* default: 6 */
--      /* Map 1..3 to 4 */
--      if (opt & 0x7)
--              opt |= 1 << 4;
--      opt = ffs(opt >> 3);
-+      opt = ffs(opt >> 4); /* Maps -1..-4 to [0], -5 to [1] ... -9 to [5] */
-       max_chain_length = 1 << gzip_level_config[opt].chain_shift;
-       good_match       = gzip_level_config[opt].good;
-       max_lazy_match   = gzip_level_config[opt].lazy2 * 2;
diff --git a/package/busybox/0003-top-move-free-prev_hist-out-of-signal-path.patch b/package/busybox/0003-top-move-free-prev_hist-out-of-signal-path.patch
new file mode 100644 (file)
index 0000000..f5e2942
--- /dev/null
@@ -0,0 +1,48 @@
+From aedc3fe19fac368dc363050e0387d263b7e01cc6 Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Fri, 19 Aug 2016 11:07:31 +0200
+Subject: [PATCH] top: move free(prev_hist) out of signal path
+
+It was seen being called recursively on repeated signals,
+leading to double free
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+Backported-from: https://git.busybox.net/busybox/commit/?id=aedc3fe19fac368dc363050e0387d263b7e01cc6
+Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
+
+---
+ procps/top.c | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/procps/top.c b/procps/top.c
+index 73cd285..6f7f7d3 100644
+--- a/procps/top.c
++++ b/procps/top.c
+@@ -728,12 +728,6 @@ static void reset_term(void)
+ {
+       if (!OPT_BATCH_MODE)
+               tcsetattr_stdin_TCSANOW(&initial_settings);
+-      if (ENABLE_FEATURE_CLEAN_UP) {
+-              clearmems();
+-# if ENABLE_FEATURE_TOP_CPU_USAGE_PERCENTAGE
+-              free(prev_hist);
+-# endif
+-      }
+ }
+ static void sig_catcher(int sig)
+@@ -1258,5 +1252,11 @@ int top_main(int argc UNUSED_PARAM, char **argv)
+ #if ENABLE_FEATURE_USE_TERMIOS
+       reset_term();
+ #endif
++      if (ENABLE_FEATURE_CLEAN_UP) {
++              clearmems();
++#if ENABLE_FEATURE_TOP_CPU_USAGE_PERCENTAGE
++              free(prev_hist);
++#endif
++      }
+       return EXIT_SUCCESS;
+ }
+-- 
+2.7.4
+
diff --git a/package/busybox/0004-ip.patch b/package/busybox/0004-ip.patch
deleted file mode 100644 (file)
index d392adc..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-From upstream: https://busybox.net/downloads/fixes-1.25.0/
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
---- busybox-1.25.0/networking/libiproute/iproute.c
-+++ busybox-1.25.0-ip/networking/libiproute/iproute.c
-@@ -362,10 +362,9 @@ IF_FEATURE_IP_RULE(ARG_table,)
-               req.r.rtm_scope = RT_SCOPE_NOWHERE;
-       if (cmd != RTM_DELROUTE) {
-+              req.r.rtm_scope = RT_SCOPE_UNIVERSE;
-               if (RTPROT_BOOT != 0)
-                       req.r.rtm_protocol = RTPROT_BOOT;
--              if (RT_SCOPE_UNIVERSE != 0)
--                      req.r.rtm_scope = RT_SCOPE_UNIVERSE;
-               if (RTN_UNICAST != 0)
-                       req.r.rtm_type = RTN_UNICAST;
-       }
diff --git a/package/busybox/0005-ntpd.patch b/package/busybox/0005-ntpd.patch
deleted file mode 100644 (file)
index f652ec6..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-From upstream: https://busybox.net/downloads/fixes-1.25.0/
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
---- busybox-1.25.0/networking/ntpd.c
-+++ busybox-1.25.0-ntpd/networking/ntpd.c
-@@ -2051,6 +2051,13 @@ recv_and_process_client_pkt(void /*int f
-               goto bail;
-       }
-+      /* Respond only to client and symmetric active packets */
-+      if ((msg.m_status & MODE_MASK) != MODE_CLIENT
-+       && (msg.m_status & MODE_MASK) != MODE_SYM_ACT
-+      ) {
-+              goto bail;
-+      }
-+
-       query_status = msg.m_status;
-       query_xmttime = msg.m_xmttime;
diff --git a/package/busybox/0006-top-move-free-prev_hist-out-of-signal-path.patch b/package/busybox/0006-top-move-free-prev_hist-out-of-signal-path.patch
deleted file mode 100644 (file)
index f5e2942..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From aedc3fe19fac368dc363050e0387d263b7e01cc6 Mon Sep 17 00:00:00 2001
-From: Denys Vlasenko <vda.linux@googlemail.com>
-Date: Fri, 19 Aug 2016 11:07:31 +0200
-Subject: [PATCH] top: move free(prev_hist) out of signal path
-
-It was seen being called recursively on repeated signals,
-leading to double free
-
-Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
-Backported-from: https://git.busybox.net/busybox/commit/?id=aedc3fe19fac368dc363050e0387d263b7e01cc6
-Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
-
----
- procps/top.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/procps/top.c b/procps/top.c
-index 73cd285..6f7f7d3 100644
---- a/procps/top.c
-+++ b/procps/top.c
-@@ -728,12 +728,6 @@ static void reset_term(void)
- {
-       if (!OPT_BATCH_MODE)
-               tcsetattr_stdin_TCSANOW(&initial_settings);
--      if (ENABLE_FEATURE_CLEAN_UP) {
--              clearmems();
--# if ENABLE_FEATURE_TOP_CPU_USAGE_PERCENTAGE
--              free(prev_hist);
--# endif
--      }
- }
- static void sig_catcher(int sig)
-@@ -1258,5 +1252,11 @@ int top_main(int argc UNUSED_PARAM, char **argv)
- #if ENABLE_FEATURE_USE_TERMIOS
-       reset_term();
- #endif
-+      if (ENABLE_FEATURE_CLEAN_UP) {
-+              clearmems();
-+#if ENABLE_FEATURE_TOP_CPU_USAGE_PERCENTAGE
-+              free(prev_hist);
-+#endif
-+      }
-       return EXIT_SUCCESS;
- }
--- 
-2.7.4
-
index e9e06915abc9b2ae125d716e7d05758ca8c42c93..8306de979d2daf5132458b33a2fa46dcd12621a1 100644 (file)
@@ -1,3 +1,3 @@
-# From http://busybox.net/downloads/busybox-1.25.0.tar.bz2.sign
-md5    b05af9645076f75429a8683f8afcbdb3        busybox-1.25.0.tar.bz2
-sha1   c6c759bf4c4f24b37f52e136e2b15d921a8d44cb        busybox-1.25.0.tar.bz2
+# From http://busybox.net/downloads/busybox-1.25.1.tar.bz2.sign
+md5    4f4c5de50b479b11ff636d7d8eb902a2        busybox-1.25.1.tar.bz2
+sha1   8b227b3efdb4c4aa94750f80cc63429aec6daa0b        busybox-1.25.1.tar.bz2
index 895f4ca9bdb745cc9d5d4c1f9247be7dd2aec614..fc23a90a29d3bdae2549d22e125d7a07f9c5834f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BUSYBOX_VERSION = 1.25.0
+BUSYBOX_VERSION = 1.25.1
 BUSYBOX_SITE = http://www.busybox.net/downloads
 BUSYBOX_SOURCE = busybox-$(BUSYBOX_VERSION).tar.bz2
 BUSYBOX_LICENSE = GPLv2