package/xmlstarlet: Fix static build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 13 Dec 2015 09:53:46 +0000 (10:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 13 Dec 2015 13:28:22 +0000 (14:28 +0100)
If libxml2 depends on xz (liblzma) static linking is broken.

Fixes
http://autobuild.buildroot.net/results/df3/df3f5fa770833c8c4344ee0bc67f45aa578ce542/
http://autobuild.buildroot.net/results/070/07021c8bd6e2031c2717fc58e2d3ff30c412fa90/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xmlstarlet/xmlstarlet.mk

index 992bb8f3ba9eb36c6d64a78f7395cc8c03f407f5..e0abf04502cac2fb948ddebc702550a01c8f5484 100644 (file)
@@ -21,6 +21,7 @@ XMLSTARLET_CONF_OPTS += \
 
 ifeq ($(BR2_STATIC_LIBS),y)
 XMLSTARLET_CONF_OPTS += --enable-static-libs
+XMLSTARLET_CONF_ENV = LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libxml-2.0`"
 else
 XMLSTARLET_CONF_OPTS += --disable-static-libs
 endif