avahi: add optional gtk3 support
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 26 Oct 2014 04:30:02 +0000 (05:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 26 Oct 2014 04:30:02 +0000 (05:30 +0100)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/avahi/avahi.mk

index 3b9ac6376a3ab11a3cfedc325e1034abe97a5256..752f2e7d5b596a598e76979302e42c52898b3f29 100644 (file)
@@ -73,7 +73,6 @@ AVAHI_CONF_OPTS = \
                --disable-gdbm \
                --disable-python-dbus \
                --disable-pygtk \
-               --disable-gtk3 \
                --disable-mono \
                --disable-monodoc \
                --disable-stack-protector \
@@ -123,6 +122,13 @@ else
 AVAHI_CONF_OPTS += --disable-gtk
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGTK3),y)
+AVAHI_DEPENDENCIES += libgtk3
+AVAHI_CONF_OPTS += --enable-gtk3
+else
+AVAHI_CONF_OPTS += --disable-gtk3
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 AVAHI_CONF_ENV += am_cv_pathless_PYTHON=python \
                am_cv_path_PYTHON=$(PYTHON_TARGET_BINARY) \