uClibc: drop BR2_PROGRAM_INVOCATION option
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Jul 2011 09:51:47 +0000 (11:51 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Jul 2011 09:56:53 +0000 (11:56 +0200)
Remove the BR option and enable the configuration setting in the
uClibc defconfigs.

The BR2_PROGRAM_INVOCATION option only adds very little overhead to
uClibc, and we have a number of packages needing it, so simply always
enable it - Simplifying the kconfig logic and the number of choices
users have to make.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
19 files changed:
package/coreutils/Config.in
package/tar/Config.in
package/udev/Config.in
package/usbutils/Config.in
package/util-linux/Config.in
target/xtensa/uClibc-0.9.30.config
target/xtensa/uClibc.config
toolchain/helpers.mk
toolchain/toolchain-buildroot/Config.in.2
toolchain/toolchain-common.in
toolchain/toolchain-crosstool-ng/Config.in
toolchain/toolchain-crosstool-ng/crosstool-ng.mk
toolchain/toolchain-crosstool-ng/uClibc.config
toolchain/toolchain-external/Config.in
toolchain/uClibc/uClibc-0.9.30.config
toolchain/uClibc/uClibc-0.9.31.config
toolchain/uClibc/uClibc-0.9.32.config
toolchain/uClibc/uClibc-snapshot.config
toolchain/uClibc/uclibc.mk

index a7159cf9ea75cfdd9d33f65d0d6705dbf39031ed..bfd6f26203c84afe8369ba1f1cb79da8e13b40ef 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_COREUTILS
        bool "coreutils"
-       depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
+       depends on BR2_USE_WCHAR
        help
          All of the basic file/text/shell utilities.  These are the
          core utilities which are expected to exist on every system.
@@ -13,5 +13,5 @@ config BR2_PACKAGE_COREUTILS
 
          http://www.gnu.org/software/coreutils/
 
-comment "coreutils requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
-       depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
+comment "coreutils requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
index 20529e378318d423b7b3e4a9c897c9bbef4fd8b4..427cae461d1363943df62ca177d2825ac1d78ffa 100644 (file)
@@ -1,11 +1,11 @@
 config BR2_PACKAGE_TAR
        bool "tar"
-       depends on BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION
+       depends on BR2_USE_WCHAR
        help
          A program that saves many files together into a single tape or disk
          archive, and can restore individual files from the archive.
 
          http://www.gnu.org/software/tar/
 
-comment "tar requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
-       depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
+comment "tar requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
index 48391e5fbbde36680deb52f3c8b89239f2824e85..67fd413d99e91142f6769f38eaff03405344f8f7 100644 (file)
@@ -11,7 +11,6 @@ config BR2_PACKAGE_UDEV_ALL_EXTRAS
        bool "enable all extras"
        depends on BR2_LARGEFILE # acl
        depends on BR2_USE_WCHAR # libglib2
-       depends on BR2_PROGRAM_INVOCATION # usbutils
        select BR2_PACKAGE_ACL
        select BR2_PACKAGE_LIBUSB
        select BR2_PACKAGE_LIBUSB_COMPAT
@@ -22,7 +21,7 @@ config BR2_PACKAGE_UDEV_ALL_EXTRAS
          Enable all extras with external dependencies like
          libacl, libusb, libusb-compat, usbutils, hwdata
 
-comment "udev extras requires a toolchain with LARGEFILE/WCHAR/PROGRAM_INVOCATION support"
-       depends on !(BR2_LARGEFILE && BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
+comment "udev extras requires a toolchain with LARGEFILE + WCHAR support"
+       depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
 
 endif
index fbd712b86d239aace8749b5a17c3c0f55cb8a25e..23004d9528566f5e24f06251fa39a67f71c76b06 100644 (file)
@@ -1,9 +1,5 @@
-comment "usbutils requires a toolchain with PROGRAM_INVOCATION support"
-       depends on !BR2_PROGRAM_INVOCATION
-
 config BR2_PACKAGE_USBUTILS
        bool "usbutils"
-       depends on BR2_PROGRAM_INVOCATION
        select BR2_PACKAGE_LIBUSB
        help
          USB enumeration utilities
index b59a31ab22f52a7def282d2df0918a88b45708b8..c0e15e7158df509dab656a4a9882debb5d5d71b0 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_UTIL_LINUX
        bool "util-linux"
        depends on BR2_LARGEFILE
        depends on BR2_USE_WCHAR
-       depends on BR2_PROGRAM_INVOCATION
        help
          Various useful/essential Linux utilities.
 
@@ -119,5 +118,5 @@ config BR2_PACKAGE_UTIL_LINUX_WRITE
 
 endif
 
-comment "util-linux requires a toolchain with LARGEFILE/WCHAR/PROGRAM_INVOCATION support"
-       depends on !(BR2_LARGEFILE && BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
+comment "util-linux requires a toolchain with LARGEFILE + WCHAR support"
+       depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
index cc6815d07ef7febc3df1b52f0605bdf7a029fb3c..5701fe474ed89459085a8e657bd0c12a1d567dfd 100644 (file)
@@ -84,7 +84,7 @@ UCLIBC_SUSV3_LEGACY=y
 UCLIBC_SUSV3_LEGACY_MACROS=y
 # UCLIBC_HAS_STUBS is not set
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
 UCLIBC_HAS___PROGNAME=y
 UCLIBC_HAS_PTY=y
 UNIX98PTY_ONLY=y
index 546a045347ea3089fd3554c03c92ddcf0dd61d91..cd82fabe62e0fc49c12b65eec62a9d642d7171ce 100644 (file)
@@ -75,7 +75,7 @@ UCLIBC_DYNAMIC_ATEXIT=y
 # UCLIBC_SUSV3_LEGACY is not set
 UCLIBC_SUSV3_LEGACY_MACROS=y
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
 UCLIBC_HAS___PROGNAME=y
 # UNIX98PTY_ONLY is not set
 ASSUME_DEVPTS=y
index 13dbebbee8145d04b699f59b30aa428c9e79b4c9..123720b87ecf183fbcbb0e2246d214f7dae8f41f 100644 (file)
@@ -148,7 +148,6 @@ check_glibc = \
        $(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
        $(call check_glibc_feature,BR2_USE_MMU,MMU support) ;\
        $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support) ;\
-       $(call check_glibc_feature,BR2_PROGRAM_INVOCATION,Program invocation support)
 
 #
 # Check the conformity of Buildroot configuration with regard to the
@@ -194,7 +193,6 @@ check_uclibc = \
        $(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
        $(call check_uclibc_feature,__UCLIBC_HAS_LOCALE__,BR2_ENABLE_LOCALE,$${UCLIBC_CONFIG_FILE},Locale support) ;\
        $(call check_uclibc_feature,__UCLIBC_HAS_WCHAR__,BR2_USE_WCHAR,$${UCLIBC_CONFIG_FILE},Wide char support) ;\
-       $(call check_uclibc_feature,__UCLIBC_HAS_PROGRAM_INVOCATION_NAME__,BR2_PROGRAM_INVOCATION,$${UCLIBC_CONFIG_FILE},Program invocation support) ;\
        $(call check_uclibc_feature,__UCLIBC_HAS_THREADS__,BR2_TOOLCHAIN_HAS_THREADS,$${UCLIBC_CONFIG_FILE},Thread support)
 
 #
index 5df188f5d45f42aaea22e4599a7b5095d7109146..e3fe3378412c044da5bb35468a619ba5fc154b1d 100644 (file)
@@ -41,16 +41,6 @@ config BR2_TOOLCHAIN_BUILDROOT_LOCALE
          Enable this option if you want your toolchain to support
          localization and internationalization.
 
-config BR2_TOOLCHAIN_BUILDROOT_PROGRAM_INVOCATION
-       bool "Enable 'program invocation name' support"
-       select BR2_PROGRAM_INVOCATION
-       help
-         Enable this option if you want your toolchain to support the
-         GNU-specific program_invocation_name and
-         program_invocation_short_name strings.  Some GNU packages
-         (like tar and coreutils) utilize these for extra useful
-         output, but in general are not required.
-
 config BR2_TOOLCHAIN_BUILDROOT_CXX
        bool "Enable C++ support"
        select BR2_INSTALL_LIBSTDCPP
index bbb7be627e3ca2cc34dd52c1976c99fae2649af3..2d11008098e77aa61a2ecd88e8e7650ccce1b2d2 100644 (file)
@@ -20,9 +20,6 @@ config BR2_USE_WCHAR
 config BR2_ENABLE_LOCALE
        bool
 
-config BR2_PROGRAM_INVOCATION
-       bool
-
 config BR2_INSTALL_LIBSTDCPP
        bool
 
index 3cac8088afa69088f16519ca1acf4a9ecccacd36..2d1e801c40fce8591eb93799527dfff2a34836d9 100644 (file)
@@ -17,7 +17,6 @@ config BR2_TOOLCHAIN_CTNG_eglibc
        select BR2_INET_RPC
        select BR2_ENABLE_LOCALE
        select BR2_USE_WCHAR
-       select BR2_PROGRAM_INVOCATION
 
 config BR2_TOOLCHAIN_CTNG_glibc
        bool "glibc"
@@ -26,7 +25,6 @@ config BR2_TOOLCHAIN_CTNG_glibc
        select BR2_INET_RPC
        select BR2_ENABLE_LOCALE
        select BR2_USE_WCHAR
-       select BR2_PROGRAM_INVOCATION
 
 endchoice # C library
 
@@ -89,16 +87,6 @@ config BR2_TOOLCHAIN_CTNG_uClibc_LOCALE
          Enable this option if you want your toolchain to support
          localization and internationalization.
 
-config BR2_TOOLCHAIN_CTNG_uClibc_PROGRAM_INVOCATION
-       bool "Enable 'program invocation name' support"
-       select BR2_PROGRAM_INVOCATION
-       help
-         Enable this option if you want your toolchain to support the
-         GNU-specific program_invocation_name and
-         program_invocation_short_name strings.  Some GNU packages
-         (like tar and coreutils) utilize these for extra useful
-         output, but in general are not required.
-
 endif # BR2_TOOLCHAIN_CTNG_uClibc
 
 config BR2_TOOLCHAIN_CTNG_CXX
index ec6e1889b020b825fff50ad415b290b279269afe..912bb06b2230bfc1b353b615222c890ab2126ac9 100644 (file)
@@ -305,13 +305,6 @@ else
 CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_RPC)=.*:\# \1 is not set:;
 endif
 
-# Handle the program_invocation_name option
-ifneq ($(call qstrip,$(BR2_PROGRAM_INVOCATION)),)
-CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^\# (UCLIBC_HAS_PROGRAM_INVOCATION_NAME) is not set:\1=y:;
-else
-CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_PROGRAM_INVOCATION_NAME)=y:\# \1 is not set:;
-endif
-
 # Instruct CT-NG's .config where to find the uClibc's .config
 CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LIBC_UCLIBC_CONFIG_FILE)=.*:\1="$(CTNG_DIR)/libc.config":;
 
index f1163ae84ca1978fdb91313eefdfa414123a660b..76a3427460c446423d967794a2c2b6ec67e03c50 100644 (file)
@@ -109,7 +109,8 @@ UCLIBC_DYNAMIC_ATEXIT=y
 # UCLIBC_SUSV3_LEGACY_MACROS is not set
 # UCLIBC_HAS_STUBS is not set
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
 UCLIBC_HAS_PTY=y
 ASSUME_DEVPTS=y
 UNIX98PTY_ONLY=y
index 8cd37d4b533d120a8b22dc680a1605c244e80b68..bedbb53d8d02102753bd78cefba46c281adb7ae3 100644 (file)
@@ -173,7 +173,6 @@ config BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2010RC1
        select BR2_INET_IPV6
        select BR2_INET_RPC
        select BR2_USE_WCHAR
-       select BR2_PROGRAM_INVOCATION
        select BR2_TOOLCHAIN_HAS_THREADS
        help
          Toolchain for the Blackfin architecture, from
@@ -231,7 +230,6 @@ config BR2_TOOLCHAIN_EXTERNAL_GLIBC
        select BR2_INET_RPC
        select BR2_USE_WCHAR
        select BR2_ENABLE_LOCALE
-       select BR2_PROGRAM_INVOCATION
        select BR2_TOOLCHAIN_HAS_THREADS
        select BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
 
@@ -300,14 +298,6 @@ config BR2_TOOLCHAIN_EXTERNAL_LOCALE
          support. If you don't know, leave the default value,
          Buildroot will tell you if it's correct or not.
 
-config BR2_TOOLCHAIN_EXTERNAL_PROGRAM_INVOCATION
-       bool "Toolchain has program invocation support?"
-       select BR2_PROGRAM_INVOCATION
-       help
-         Select this option if your external toolchain has program
-         invocation support. If you don't know, leave the default
-         value, Buildroot will tell you if it's correct or not.
-
 config BR2_TOOLCHAIN_EXTERNAL_HAS_THREADS
        bool "Toolchain has threads support?"
        select BR2_TOOLCHAIN_HAS_THREADS
index 2202b9e14f5aee4e3c40abb3259c2f8c16b5772b..49ac3ef4cb95246519868816378a6bd9502f65d4 100644 (file)
@@ -82,7 +82,7 @@ UCLIBC_DYNAMIC_ATEXIT=y
 # UCLIBC_SUSV3_LEGACY_MACROS is not set
 # UCLIBC_HAS_STUBS is not set
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
 UCLIBC_HAS___PROGNAME=y
 UCLIBC_HAS_PTY=y
 ASSUME_DEVPTS=y
index 60b462806191d34a2107f2d3c5a182897936ca6b..80210c5df83eb4f9824fe460c4a40576ec972ca3 100644 (file)
@@ -89,8 +89,8 @@ UCLIBC_SUSV3_LEGACY=y
 UCLIBC_SUSV4_LEGACY=y
 # UCLIBC_HAS_STUBS is not set
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
-# UCLIBC_HAS___PROGNAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
 UCLIBC_HAS_PTY=y
 ASSUME_DEVPTS=y
 UNIX98PTY_ONLY=y
index 5a7b52a9a231dfadec17390640789c0304376ab3..e9f942d63b0abdbc50f51232bd32a4f3f06f14d1 100644 (file)
@@ -113,8 +113,8 @@ UCLIBC_SUSV4_LEGACY=y
 # UCLIBC_STRICT_HEADERS is not set
 # UCLIBC_HAS_STUBS is not set
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
-# UCLIBC_HAS___PROGNAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
 UCLIBC_HAS_PTY=y
 ASSUME_DEVPTS=y
 UNIX98PTY_ONLY=y
index 34ec0ff01f5473501f477ef2d4d0f54b35c577af..bff7584694ac79d5a1e48fd91b4981b850c1ced5 100644 (file)
@@ -113,8 +113,8 @@ UCLIBC_SUSV4_LEGACY=y
 # UCLIBC_STRICT_HEADERS is not set
 # UCLIBC_HAS_STUBS is not set
 UCLIBC_HAS_SHADOW=y
-# UCLIBC_HAS_PROGRAM_INVOCATION_NAME is not set
-# UCLIBC_HAS___PROGNAME is not set
+UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y
+UCLIBC_HAS___PROGNAME=y
 UCLIBC_HAS_PTY=y
 ASSUME_DEVPTS=y
 UNIX98PTY_ONLY=y
index 3173ef4bb1087e49793640dad18bfb69f0a54a3b..e74012f6165d9bdd6709a20fc6f66ac15a762b55 100644 (file)
@@ -318,13 +318,6 @@ ifeq ($(BR2_USE_WCHAR),y)
 else
        $(SED) 's,^.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=n,g' $(UCLIBC_DIR)/.oldconfig
 endif
-ifeq ($(BR2_PROGRAM_INVOCATION),y)
-       $(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=y,g' $(UCLIBC_DIR)/.oldconfig
-       $(SED) 's,^.*UCLIBC_HAS___PROGNAME.*,UCLIBC_HAS___PROGNAME=y,g' $(UCLIBC_DIR)/.oldconfig
-else
-       $(SED) 's,^.*UCLIBC_HAS_PROGRAM_INVOCATION_NAME.*,UCLIBC_HAS_PROGRAM_INVOCATION_NAME=n,g' $(UCLIBC_DIR)/.oldconfig
-       $(SED) 's,^.*UCLIBC_HAS___PROGNAME.*,UCLIBC_HAS___PROGNAME=n,g' $(UCLIBC_DIR)/.oldconfig
-endif
 ifeq ("$(KERNEL_ARCH)","i386")
        /bin/echo "# CONFIG_GENERIC_386 is not set" >> $(UCLIBC_DIR)/.oldconfig
        /bin/echo "# CONFIG_386 is not set" >> $(UCLIBC_DIR)/.oldconfig