Remove unused .fakeroot.* mechanism
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Apr 2012 14:45:21 +0000 (16:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 19 Apr 2012 14:09:30 +0000 (16:09 +0200)
There used to be a mechanism using which packages could leave a
.fakeroot.<something> file which could contain commands to be executed
within the fakeroot environment. Since this mechanism is no longer
used by any package, remove it from the common infrastructure.

The latest user was nfs-utils, which used this mechanism to do the
"make install" as root, since doing otherwise was not supported. But
since 16e7b8255c82815126a2c502c3787d442d254a86, nfs-utils has been
upgraded and converted to the package infrastructure, and this hack is
no longer necessary. Another past user was the ltp-testsuite package,
for the same reason, and since
a72a670489547a3ca645ff7c3a0d9c3fb66eab51, the fakeroot hack is no
longer needed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
fs/common.mk
fs/iso9660/iso9660.mk

index bb3a49bf9e5e393003aa420853d0314ef562aca4..845858044d88a74823036528f91f8042f60e30d4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -302,8 +302,6 @@ endif
 
 include fs/common.mk
 
-TARGETS+=erase-fakeroots
-
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
 TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
 TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
@@ -392,7 +390,6 @@ $(BUILD_DIR)/.root:
                if [ -d "$(TARGET_SKELETON)" ]; then \
                        cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
                fi; \
-               touch $(STAGING_DIR)/.fakeroot.00000; \
        fi
        -find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
        -find $(TARGET_DIR) -type f \( -name .empty -o -name '*~' \) -print0 | xargs -0 rm -rf
@@ -400,9 +397,6 @@ $(BUILD_DIR)/.root:
 
 $(TARGET_DIR): $(BUILD_DIR)/.root
 
-erase-fakeroots:
-       rm -f $(BUILD_DIR)/.fakeroot*
-
 target-finalize:
 ifeq ($(BR2_HAVE_DEVFILES),y)
        ( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
index d426f3796654add8422148a1c09b5bd725a7f5a4..debf7db65f70fbae31d2c4bb2cda689f2213c3aa 100644 (file)
@@ -45,8 +45,6 @@ $(BINARIES_DIR)/rootfs.$(1): $(ROOTFS_$(2)_DEPENDENCIES)
        @$(call MESSAGE,"Generating root filesystem image rootfs.$(1)")
        $(foreach hook,$(ROOTFS_$(2)_PRE_GEN_HOOKS),$(call $(hook))$(sep))
        rm -f $(FAKEROOT_SCRIPT)
-       touch $(BUILD_DIR)/.fakeroot.00000
-       cat $(BUILD_DIR)/.fakeroot* > $(FAKEROOT_SCRIPT)
        echo "chown -R 0:0 $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
 ifneq ($(ROOTFS_DEVICE_TABLES),)
        cat $(ROOTFS_DEVICE_TABLES) > $(FULL_DEVICE_TABLE)
index afebafcd8a1aa63aeb868a9d7108e9a8bc4c70fe..f51b6ee868a1b2477097a5cf83ea7f6c4c0c9aad 100644 (file)
@@ -25,8 +25,6 @@ $(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux rootfs-ext2 grub
        cp $(BINARIES_DIR)/rootfs.ext2 $(ISO9660_TARGET_DIR)/initrd
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(FAKEROOT_SCRIPT)
-       touch $(BUILD_DIR)/.fakeroot.00000
-       cat $(BUILD_DIR)/.fakeroot* > $(FAKEROOT_SCRIPT)
        echo "chown -R 0:0 $(ISO9660_TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
        # Use fakeroot so mkisofs believes the previous fakery
        echo "$(HOST_DIR)/usr/bin/genisoimage -R -b boot/grub/stage2_eltorito -no-emul-boot " \