package/efl: remove wayland dependency
authorRomain Naour <romain.naour@gmail.com>
Fri, 11 Nov 2016 08:54:06 +0000 (09:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 11 Nov 2016 14:05:56 +0000 (15:05 +0100)
Wayland support requires DRM support in efl libraries since 1.18 bump,
but this support is not merged yet in Buildroot and waiting for review
[1].

For 2016.11, keep wayland support disabled to avoid build issues.

Fixes:
http://autobuild.buildroot.net/results/162133cbddcca1ea8be660a19771f04296c20fd2

[1] http://patchwork.ozlabs.org/patch/671260/
    http://patchwork.ozlabs.org/patch/671261/

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/Config.in
package/efl/efl.mk

index f963ade8e5605d76e3c609174e2699858a901200..69b0dcfb3965668bd7f6502a9d4f958a829665f8 100644 (file)
@@ -14,7 +14,6 @@ config BR2_PACKAGE_EFL
        select BR2_PACKAGE_FREETYPE
        select BR2_PACKAGE_JPEG # Emile needs libjpeg
        select BR2_PACKAGE_LIBCURL # Ecore_con_url, runtime dependency
-       select BR2_PACKAGE_LIBXKBCOMMON if BR2_PACKAGE_WAYLAND
        # https://phab.enlightenment.org/T2728
        select BR2_PACKAGE_LUAJIT # Lua support broken
        select BR2_PACKAGE_UTIL_LINUX
index 777ef3c848ae7072c9d1fda01ebbc1d8dfc3934f..6af7aa0c5e44875eddb57dcfb49ca9c37d7cedeb 100644 (file)
@@ -42,6 +42,7 @@ EFL_CONF_OPTS = \
        --disable-sdl \
        --disable-spectre \
        --disable-xinput22 \
+       --disable-wayland \
        --with-doxygen=no
 
 # Disable untested configuration warning.
@@ -145,13 +146,6 @@ else
 EFL_CONF_OPTS += --with-crypto=none
 endif # BR2_PACKAGE_OPENSSL
 
-ifeq ($(BR2_PACKAGE_WAYLAND),y)
-EFL_DEPENDENCIES += wayland libxkbcommon
-EFL_CONF_OPTS += --enable-wayland
-else
-EFL_CONF_OPTS += --disable-wayland
-endif
-
 ifeq ($(BR2_PACKAGE_EFL_ELPUT),y)
 EFL_CONF_OPTS += --enable-elput
 EFL_DEPENDENCIES += libinput libxkbcommon