cjson: fix error with sh4a and powerpc
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 15 Dec 2016 18:08:59 +0000 (19:08 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 15 Dec 2016 21:10:30 +0000 (22:10 +0100)
Fixes:
 - http://autobuild.buildroot.net/results/3d899790acdc5c21733ff6f7f5a1b500e862ea0a

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cjson/cjson.hash
package/cjson/cjson.mk

index 4f0723a5100bbd1dc9c42849f5ab201a4f833e6d..fc0ed28df6b7c3bb5835edc033c3f664b8307381 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed:
 sha256 3487795d54440bdbd41b4b8e7688889526f2f9a652639f6036b9965016c800e7        cjson-v1.1.0.tar.gz
+sha256 8eea780ee5729275a5076002d92a4c7854ecb89968b26a81efeb5bd9828268a0        fcc89c4bb264d665929b00eeebc479a643a90896.patch
index 3dd6ebc77aa7e1888ad15bbd7f9b41666d862e59..7ac7a71dcc851c5abe3bc0207d145bb902f025c7 100644 (file)
@@ -10,4 +10,10 @@ CJSON_INSTALL_STAGING = YES
 CJSON_LICENSE = MIT
 CJSON_LICENSE_FILES = LICENSE
 
+# This patch fixes -Werror=strict-overflow compile errors on sh4a and powerpc
+# toolchains:
+# http://autobuild.buildroot.net/results/3d899790acdc5c21733ff6f7f5a1b500e862ea0a
+CJSON_PATCH = \
+       https://github.com/DaveGamble/cjson/commit/fcc89c4bb264d665929b00eeebc479a643a90896.patch
+
 $(eval $(cmake-package))