python-lxml: allow build as host package
authorCarlos Santos <casantos@datacom.ind.br>
Wed, 1 Feb 2017 17:51:08 +0000 (15:51 -0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Apr 2017 16:43:49 +0000 (18:43 +0200)
While currently there is no in-tree Buildroot package which depends on
host-python-lxml, we (DATACOM) have some proprietary modules that use it
in their test scripts.

We tested python-lxml as host package and confirmed that it builds and
works correctly. Someone else might require it, so we are proposing its
inclusion.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
[Thomas: add Config.in.host entry.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/python-lxml/Config.in.host [new file with mode: 0644]
package/python-lxml/python-lxml.mk

index bb91671f3355956002290a238c8fc17857630687..38f919a985457de9a4c17edf54ac5ecdb951898e 100644 (file)
@@ -36,6 +36,7 @@ menu "Host utilities"
        source "package/patchelf/Config.in.host"
        source "package/pru-software-support/Config.in.host"
        source "package/pwgen/Config.in.host"
+       source "package/python-lxml/Config.in.host"
        source "package/qemu/Config.in.host"
        source "package/raspberrypi-usbboot/Config.in.host"
        source "package/s6-rc/Config.in.host"
diff --git a/package/python-lxml/Config.in.host b/package/python-lxml/Config.in.host
new file mode 100644 (file)
index 0000000..580e440
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_HOST_PYTHON_LXML
+       bool "host python-lxml"
+       help
+         The lxml XML toolkit is a Pythonic binding for the C libraries
+         libxml2 and libxslt.
+
+         http://lxml.de/
+
index bb060d7ea66d530e333ed5f3e53e4b448e07bda0..40fb77351e33ff1255de0b9a234697fbf95a6146 100644 (file)
@@ -21,11 +21,16 @@ PYTHON_LXML_LICENSE_FILES = \
 PYTHON_LXML_SETUP_TYPE = setuptools
 
 PYTHON_LXML_DEPENDENCIES = libxml2 libxslt zlib
+HOST_PYTHON_LXML_DEPENDENCIES = host-libxml2 host-libxslt host-zlib
 
 # python-lxml needs these scripts in order to properly detect libxml2 and
 # libxslt compiler and linker flags
 PYTHON_LXML_BUILD_OPTS = \
        --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config \
        --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config
+HOST_PYTHON_LXML_BUILD_OPTS = \
+       --with-xslt-config=$(HOST_DIR)/usr/bin/xslt-config \
+       --with-xml2-config=$(HOST_DIR)/usr/bin/xml2-config
 
 $(eval $(python-package))
+$(eval $(host-python-package))