libcurl: specify capath
authorShawn J. Goff <shawn7400@gmail.com>
Wed, 17 Apr 2013 11:31:27 +0000 (11:31 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 21 Apr 2013 21:15:08 +0000 (23:15 +0200)
Since openssl's path is '/etc/ssl/' (specified in our openssl package),
we should also make sure that's what curl is using.

Previously, it's hasn't been specified, which means it changes depending
on the host system where it's compiled.

Signed-off-by: Shawn J. Goff <shawn7400@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libcurl/libcurl.mk

index a631953af0aad4c2ae2bd38330fb119a220ebeec..f0236d97fa6dc629eff4525eef107dd1db4f979e 100644 (file)
@@ -27,7 +27,9 @@ LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
 # Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
 # are found first.
 LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:/lib:/usr/lib
-LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr --with-random=/dev/urandom
+LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr \
+       --with-random=/dev/urandom \
+       --with-ca-path=/etc/ssl/certs
 else
 LIBCURL_CONF_OPT += --without-ssl
 endif