libtirpc: add host package
authorBaruch Siach <baruch@tkos.co.il>
Wed, 23 May 2018 17:44:45 +0000 (20:44 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 May 2018 21:23:38 +0000 (23:23 +0200)
The libtirpc host package is only for two headers that the host rpcgen
utility from the nfs-utils package needs to build. glibc used to provide
these headers. In version 2.26 glibc deprecated them with its bundled
Sun RPC. Recently Fedora stopped enabling Sun RPC in glibc. So we can no
longer rely on these headers being present on the host.

Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libtirpc/libtirpc.mk

index d9bf22b83eda8ae6c8a721904810b4efd9062b35..7bc361dc691d403a4195188ed083fababef9f501 100644 (file)
@@ -18,4 +18,11 @@ LIBTIRPC_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DGQ"
 
 LIBTIRPC_CONF_OPTS = --disable-gssapi
 
+define HOST_LIBTIRPC_INSTALL_CMDS
+       $(INSTALL) -D -m 0644 $(@D)/tirpc/rpc/types.h $(HOST_DIR)/include/rpc/types.h
+       $(INSTALL) -D -m 0644 $(@D)/tirpc/netconfig.h $(HOST_DIR)/include/netconfig.h
+endef
+
 $(eval $(autotools-package))
+# We are only copying headers; no need for the autotools infrastructure
+$(eval $(host-generic-package))