- make sure that strip and all it's arguments are passed if used via
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 29 Sep 2007 10:05:08 +0000 (10:05 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 29 Sep 2007 10:05:08 +0000 (10:05 -0000)
  STRIP=$(TARGET_STRIP) (i.e. without quoting). Thanks to Dimitry Golubovsky
  for mentioning this.

package/Makefile.in

index 66e6f00f57e5d9de8161b17a4cc4ae6c9c948bbe..81b9eb2d004223a2f552dad3bf2162302051a8ba 100644 (file)
@@ -109,7 +109,7 @@ STRIP_STRIP_UNNEEDED:=--strip-unneeded
 STRIP_STRIP_ALL:=--strip-all
 REMOVE_SECTION_COMMENT:=--remove-section=.comment
 REMOVE_SECTION_NOTE:=--remove-section=.note
-TARGET_STRIP=$(TARGET_CROSS)strip $(REMOVE_SECTION_COMMENT) $(REMOVE_SECTION_NOTE)
+TARGET_STRIP="$(TARGET_CROSS)strip $(REMOVE_SECTION_COMMENT) $(REMOVE_SECTION_NOTE)"
 STRIP=$(TARGET_STRIP)
 endif
 ifeq ($(BR2_STRIP_sstrip),y)
@@ -118,11 +118,11 @@ STRIP_STRIP_UNNEEDED:=
 STRIP_STRIP_ALL:=
 REMOVE_SECTION_COMMENT:=
 REMOVE_SECTION_NOTE:=
-TARGET_STRIP=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
+TARGET_STRIP="$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip"
 STRIP=$(TARGET_STRIP)
 endif
 ifeq ($(BR2_STRIP_none),y)
-TARGET_STRIP=true -Not_stripping
+TARGET_STRIP="true -Not_stripping"
 STRIP=$(TARGET_STRIP)
 endif
 INSTALL=/usr/bin/install