brotli: new package
authorAdrian Perez de Castro <aperez@igalia.com>
Fri, 23 Mar 2018 18:59:39 +0000 (20:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 24 Mar 2018 10:45:26 +0000 (11:45 +0100)
Add the brotli package to Buildroot. This is needed by woff2, which in
turn is needed by webkitgtk from version 2.20.0 onwards. WebKitGTK+ used
to bundle a copy of the library, but it stopped doing so now that the
upstream has started making releases.

[Peter: fix license hash]
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/brotli/Config.in [new file with mode: 0644]
package/brotli/brotli.hash [new file with mode: 0644]
package/brotli/brotli.mk [new file with mode: 0644]

index 1faefc45fc7b1c1e1e7c9f47f506bb5710dc5b29..2d5f2108a85f1591ad1f175a624ea3a2891d749d 100644 (file)
@@ -62,6 +62,7 @@ F:    package/setools/
 F:     package/sngrep/
 
 N:     Adrian Perez de Castro <aperez@igalia.com>
+F:     package/brotli/
 F:     package/libepoxy/
 F:     package/webkitgtk/
 
index 58dfd6306dc7edb24e27f628a1611206da0074fb..26ded5ebb2227803618d5bff35905dc98802c54a 100644 (file)
@@ -63,6 +63,7 @@ menu "Audio and video applications"
 endmenu
 
 menu "Compressors and decompressors"
+       source "package/brotli/Config.in"
        source "package/bzip2/Config.in"
        source "package/gzip/Config.in"
        source "package/lz4/Config.in"
diff --git a/package/brotli/Config.in b/package/brotli/Config.in
new file mode 100644 (file)
index 0000000..e40f5b6
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_BROTLI
+       bool "brotli"
+       help
+         Generic-purpose lossless compression library. The algorithm
+         compresses data using a combination of a modern variant of
+         the LZ77 algorithm, Huffman coding and 2nd order context
+         modeling, with a compression ratio comparable to the best
+         currently available general-purpose compression methods. It
+         is similar in speed with deflate but offers more dense
+         compression.
+
+         https://github.com/google/brotli
diff --git a/package/brotli/brotli.hash b/package/brotli/brotli.hash
new file mode 100644 (file)
index 0000000..954d44e
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally generated:
+sha512  93adcf437d730ac403e444285ac8aefbb2c8a6b5e1b064e8ee33684c067287a8159e0ee73d2217c167881e87da73fa494792d963a15508fd42b2ac4a5b52823c  v1.0.3.tar.gz
+
+# Hash for license files:
+sha512  bae78184c2f50f86d8c727826d3982c469454c42b9af81f4ef007e39036434fa894cf5be3bf5fc65b7de2301f0a72d067a8186e303327db8a96bd14867e0a3a8  LICENSE
diff --git a/package/brotli/brotli.mk b/package/brotli/brotli.mk
new file mode 100644 (file)
index 0000000..cf1e811
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# brotli
+#
+################################################################################
+
+BROTLI_VERSION = 1.0.3
+BROTLI_SOURCE = v$(BROTLI_VERSION).tar.gz
+BROTLI_SITE = https://github.com/google/brotli/archive
+BROTLI_LICENSE = MIT
+BROTLI_LICENSE_FILES = LICENSE
+BROTLI_INSTALL_STAGING = YES
+BROTLI_CONF_OPTS = \
+       -DBROTLI_DISABLE_TESTS=ON \
+       -DBROTLI_BUNDLED_MODE=OFF
+
+$(eval $(cmake-package))