package/pure-ftpd: add optional openldap dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 27 Mar 2019 16:46:44 +0000 (17:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 27 Mar 2019 19:14:31 +0000 (20:14 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pure-ftpd/pure-ftpd.mk

index ae3ca9d1f0b709c7dda03b3a664349649689bdb9..7012268874c78e4e5b0caa8369eef9e923385abd 100644 (file)
@@ -31,6 +31,13 @@ ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
 PURE_FTPD_DEPENDENCIES += libsodium
 endif
 
+ifeq ($(BR2_PACKAGE_OPENLDAP),y)
+PURE_FTPD_CONF_OPTS += --with-ldap
+PURE_FTPD_DEPENDENCIES += openldap
+else
+PURE_FTPD_CONF_OPTS += --without-ldap
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 PURE_FTPD_CONF_OPTS += --with-tls
 PURE_FTPD_DEPENDENCIES += openssl