python3: do not use hg when available
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 Aug 2016 20:38:29 +0000 (22:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Sep 2016 15:11:49 +0000 (17:11 +0200)
During the execution of its configure script, Python 3 tries to find an
available "hg" installation, and if available, will try to use it to get
information from the version control system. To do this, it tries to
communicate over the network, potentially over ports that are blocked,
causing the build to halt. This was reported by a user as part of bug
7802.

To solve this, we simply make the Python script use /bin/false as the
"hg" program.

Fixes bug #7802 for the python3 package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python3/python3.mk

index 34e1297563146f814e49c68686041586c82ce22a..393b9fb2acc389474523e38e670efc762cd8cd9a 100644 (file)
@@ -41,8 +41,11 @@ HOST_PYTHON3_CONF_OPTS +=    \
 # Make sure that LD_LIBRARY_PATH overrides -rpath.
 # This is needed because libpython may be installed at the same time that
 # python is called.
+# Make python believe we don't have 'hg', so that it doesn't try to
+# communicate over the network during the build.
 HOST_PYTHON3_CONF_ENV += \
-       LDFLAGS="$(HOST_LDFLAGS) -Wl,--enable-new-dtags"
+       LDFLAGS="$(HOST_LDFLAGS) -Wl,--enable-new-dtags" \
+       ac_cv_prog_HAS_HG=/bin/false
 
 PYTHON3_DEPENDENCIES = host-python3 libffi
 
@@ -110,11 +113,14 @@ else
 PYTHON3_CONF_OPTS += --disable-ossaudiodev
 endif
 
+# Make python believe we don't have 'hg', so that it doesn't try to
+# communicate over the network during the build.
 PYTHON3_CONF_ENV += \
        ac_cv_have_long_long_format=yes \
        ac_cv_file__dev_ptmx=yes \
        ac_cv_file__dev_ptc=yes \
-       ac_cv_working_tzset=yes
+       ac_cv_working_tzset=yes \
+       ac_cv_prog_HAS_HG=/bin/false
 
 # uClibc is known to have a broken wcsftime() implementation, so tell
 # Python 3 to fall back to strftime() instead.