libsha1: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Jan 2013 11:29:23 +0000 (11:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 12 Jan 2013 21:37:02 +0000 (22:37 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libsha1/Config.in [new file with mode: 0644]
package/libsha1/libsha1.mk [new file with mode: 0644]

index bd1db6b88465b7bb62778df0e64cc306cefbdd3d..fcc248011edd8227fd83bf3938c8842be478fac3 100644 (file)
@@ -371,6 +371,7 @@ source "package/gnutls/Config.in"
 source "package/libgcrypt/Config.in"
 source "package/libgpg-error/Config.in"
 source "package/libnss/Config.in"
+source "package/libsha1/Config.in"
 source "package/nettle/Config.in"
 source "package/ocf-linux/Config.in"
 source "package/openssl/Config.in"
diff --git a/package/libsha1/Config.in b/package/libsha1/Config.in
new file mode 100644 (file)
index 0000000..5467a6c
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBSHA1
+       bool "libsha1"
+       help
+         libsha1 is a tiny library providing SHA1 implementation,
+         created for facilitating X server compilation on devices
+         when larger libraries containing SHA1 implementations
+         (OpenSSL, Mozilla NSS) are not needed.
+
+         https://github.com/dottedmag/libsha1
diff --git a/package/libsha1/libsha1.mk b/package/libsha1/libsha1.mk
new file mode 100644 (file)
index 0000000..e9658af
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libsha1
+#
+#############################################################
+
+LIBSHA1_VERSION = 0.3
+LIBSHA1_SITE = http://github.com/dottedmag/libsha1/tarball/$(LIBSHA1_VERSION)
+LIBSHA1_INSTALL_STAGING = YES
+
+# We're getting the source code from Github, so there is no generated
+# configure script in the tarball.
+LIBSHA1_AUTORECONF = YES
+
+$(eval $(autotools-package))