package/libglib2: restore use of system printf
authorJohn Keeping <john@metanate.com>
Wed, 11 Mar 2020 11:22:56 +0000 (11:22 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Apr 2020 20:51:14 +0000 (22:51 +0200)
Prior to commit 4102db0f7a ("package/libglib2: bump to version 2.60.3")
which converted libglib2 to meson, Buildroot used to set a range of
autoconf options to bypass tests that require running binaries.

The meson version of libglib2's build system has many fewer of these
checks, but there are still some and these can be fed the "correct"
answer by adding properties to cross-compilation.conf.

Add the necessary properties to indicate that we have C99 compliant
print functions to avoid pulling in the gnulib fallback.

Signed-off-by: John Keeping <john@metanate.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libglib2/libglib2.mk

index f9e45f70aa999345f64d412ceb721e39d0e9f1ee..7106124d7290ec39a6fe54299b361842e33116ef 100644 (file)
@@ -52,6 +52,11 @@ LIBGLIB2_CONF_OPTS = \
        -Dinstalled_tests=false \
        -Doss_fuzz=disabled
 
+LIBGLIB2_MESON_EXTRA_PROPERTIES = \
+       have_c99_vsnprintf=true \
+       have_c99_snprintf=true \
+       have_unix98_printf=true
+
 ifneq ($(BR2_ENABLE_LOCALE),y)
 LIBGLIB2_DEPENDENCIES += libiconv
 endif