package/llvm: remove $ORIGIN/../lib from RPATH
authorValentin Korenblit <valentin.korenblit@smile.fr>
Thu, 12 Apr 2018 12:36:28 +0000 (14:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 12 Apr 2018 19:12:51 +0000 (21:12 +0200)
AddLLVM.cmake adds $ORIGIN/../lib to the RPATH of llvm binaries.  This
causes a problem when llvm-config built for the host, installed in
STAGING_DIR, is executed under the following conditions:

* Target architecture same as host architecture (normally x86_64)
* Target's libc different from host's libc (normally glibc)

llvm-config will try to link with the target's libc, resulting in:

./llvm-config: error while loading shared libraries: libc.so.0: cannot open shared object file: No such file or directory.

To avoid this, we simply add pass
-DCMAKE_INSTALL_RPATH="$(HOST_DIR)/lib" in HOST_LLVM_CONF_OPTS.

Link to discussion:

  http://lists.busybox.net/pipermail/buildroot/2018-April/218627.html

Fixes:

  http://autobuild.buildroot.net/results/b81c12d529c66a028e2297ea5ce1d6930324fa69/

Signed-off-by: Valentin Korenblit <valentin.korenblit@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/llvm/llvm.mk

index 9c8bf5c820be0a3b9e966637a4d4e14058b4ca84..de2ca38da1811239db1763b2243a31ef106443b6 100644 (file)
@@ -25,6 +25,11 @@ LLVM_CONF_OPTS += -DLLVM_ENABLE_PROJECTS=""
 HOST_LLVM_CONF_OPTS += -DLLVM_CCACHE_BUILD=$(if $(BR2_CCACHE),ON,OFF)
 LLVM_CONF_OPTS += -DLLVM_CCACHE_BUILD=$(if $(BR2_CCACHE),ON,OFF)
 
+# This option prevents AddLLVM.cmake from adding $ORIGIN/../lib to
+# binaries. Otherwise, llvm-config (host variant installed in STAGING)
+# will try to use target's libc.
+HOST_LLVM_CONF_OPTS += -DCMAKE_INSTALL_RPATH="$(HOST_DIR)/lib"
+
 # Disable experimental Global Instruction Selection support.
 # https://llvm.org/docs/GlobalISel.html
 HOST_LLVM_CONF_OPTS += -DLLVM_BUILD_GLOBAL_ISEL=OFF