rrdtool: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:18:42 +0000 (23:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:35:41 +0000 (01:35 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rrdtool/Config.in
package/rrdtool/rrdtool.mk

index 3d8c0c6444b00accf2f1bab4ab3987d71dbcb6bd..631ed32847c1064914b88b0679855f4864f77934 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_RRDTOOL
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
        depends on BR2_USE_MMU # libglib2
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        help
          RRDtool is the OpenSource industry standard, high performance
          data logging and graphing system for time series data.
index 028b7cbbb67e0eb0863b9941974dc06c98339444..ea5c892e4a148ddb6e088e8d98c9e7d5bb559921 100644 (file)
@@ -8,7 +8,7 @@ RRDTOOL_VERSION = 1.6.0
 RRDTOOL_SITE = http://oss.oetiker.ch/rrdtool/pub
 RRDTOOL_LICENSE = GPL-2.0+ with FLOSS license exceptions as explained in COPYRIGHT
 RRDTOOL_LICENSE_FILES = COPYRIGHT LICENSE
-RRDTOOL_DEPENDENCIES = host-pkgconf libglib2
+RRDTOOL_DEPENDENCIES = host-pkgconf libglib2 $(TARGET_NLS_DEPENDENCIES)
 # autoreconf needed to avoid link failure due to missing -lintl,
 # gettextize needed as a consequence of autoreconf
 RRDTOOL_AUTORECONF = YES
@@ -25,10 +25,6 @@ RRDTOOL_CONF_OPTS = \
        --disable-ruby \
        --disable-tcl
 
-ifeq ($(BR2_NEEDS_GETTEXT),y)
-RRDTOOL_DEPENDENCIES += gettext
-endif
-
 ifeq ($(BR2_PACKAGE_RRDTOOL_RRDGRAPH),y)
 RRDTOOL_DEPENDENCIES += cairo pango
 else