package/cups: add _PRE_CONFIGURE_HOOKS for proper autoconf
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 May 2016 17:38:23 +0000 (19:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jun 2016 20:05:03 +0000 (22:05 +0200)
cups uses only autoconf, also using autoheader is broken:
https://github.com/apple/cups/issues/4667#issuecomment-197689571

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cups/0001-Remove-man-from-BUILDDIRS-in-configure.patch
package/cups/cups.mk

index c0e87a4e5c339b03b0e6f4802e49add58ea03517..30002d3c8f0adec584a08bfada1ef71ffe9a2816 100644 (file)
@@ -1,21 +1,18 @@
-From a77bb18a5584bb23687ed3c522dbd91a9987d5a7 Mon Sep 17 00:00:00 2001
-From: Olivier Schonken <olivier.schonken@gmail.com>
-Date: Wed, 20 Jan 2016 22:13:11 +0200
+From 6bc1d15250841cf17d307cfb4f35c960c23d8797 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sun, 29 May 2016 19:31:50 +0200
 Subject: [PATCH] Remove man from BUILDDIRS in configure
 
-Since cups doesn't autoreconf properly, we directly patch the
-configure script.
-
-Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 ---
- configure | 2 +-
+ config-scripts/cups-common.m4 | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/configure b/configure
-index 4170ff3..3879a75 100755
---- a/configure
-+++ b/configure
-@@ -5921,7 +5921,7 @@ fi
+diff --git a/config-scripts/cups-common.m4 b/config-scripts/cups-common.m4
+index fbba715..77d0f5c 100644
+--- a/config-scripts/cups-common.m4
++++ b/config-scripts/cups-common.m4
+@@ -446,7 +446,7 @@ AC_ARG_WITH(components, [  --with-components       set components to build:
  
  case "$COMPONENTS" in
        all)
@@ -25,5 +22,5 @@ index 4170ff3..3879a75 100755
  
        core)
 -- 
-2.5.0
+2.8.1
 
index c07dcb4640252ae106a85c3d1abea945bc943fe2..797d31af3c495d74fba1df471856f0b0452988ce 100644 (file)
@@ -13,6 +13,12 @@ CUPS_INSTALL_STAGING = YES
 CUPS_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) DSTROOT=$(STAGING_DIR) install
 CUPS_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) DSTROOT=$(TARGET_DIR) install
 
+# Using autoconf, not autoheader, so we cannot use AUTORECONF = YES.
+define CUPS_RUN_AUTOCONF
+       cd $(@D); $(HOST_DIR)/usr/bin/autoconf -f
+endef
+CUPS_PRE_CONFIGURE_HOOKS += CUPS_RUN_AUTOCONF
+
 CUPS_CONF_OPTS = \
        --without-perl \
        --without-java \
@@ -21,6 +27,7 @@ CUPS_CONF_OPTS = \
        --libdir=/usr/lib
 CUPS_CONFIG_SCRIPTS = cups-config
 CUPS_DEPENDENCIES = \
+       host-autoconf \
        $(if $(BR2_PACKAGE_ZLIB),zlib)
 
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)