rygel: fix UI build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 8 Jan 2018 18:10:42 +0000 (19:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 8 Jan 2018 19:57:25 +0000 (20:57 +0100)
Add a patch to avoid failing on a configure error if UI example can't be
built if libgtk3 is available but not gst1-plugins-base (gstreamer-video
is only needed for UI example, not for rygel UI)

Fixes:
 - http://autobuild.buildroot.net/results/6c659aadfc418c0a27a93284eb34d75e2b0dc169

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rygel/0001-Allow-UI-build-without-gstreamer-video.patch [new file with mode: 0644]
package/rygel/rygel.mk

diff --git a/package/rygel/0001-Allow-UI-build-without-gstreamer-video.patch b/package/rygel/0001-Allow-UI-build-without-gstreamer-video.patch
new file mode 100644 (file)
index 0000000..6e1f528
--- /dev/null
@@ -0,0 +1,37 @@
+From f3a49ad1a4ba172e97bd860bc067f7e9ebe69509 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Mon, 8 Jan 2018 13:27:42 +0100
+Subject: [PATCH] Allow UI build without gstreamer-video
+
+If EXAMPLE_UI dependencies are not met, only display a warning.
+Indeed, currently, we can't build rygel UI without gstreamer-video which
+is only a dependency of fullscreen-renderer application.
+
+fullscreen-renderer won't be build without gstreamer as HAVE_GSTREAMER
+has to be true to check HAVE_UI in examples/Makefile.am
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 00b94da..d140a27 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -359,7 +359,11 @@ if test x$try_ui = xyes ; then
+                           [$RYGEL_COMMON_MODULES gio-2.0 >= $GIO_REQUIRED
+                            gssdp-1.0 >= $GSSDP_REQUIRED
+                            gstreamer-video-1.0 >= $GSTREAMER_REQUIRED
+-                           gtk+-3.0 >= $GTK_REQUIRED])
++                           gtk+-3.0 >= $GTK_REQUIRED],,
++                          [
++                           AC_MSG_WARN([Example UI dependencies not found.])
++                           AC_MSG_WARN([Example UI applications will not be built.])
++                          ])
+       ],
+       [
+         AC_MSG_WARN([UI dependencies not found.])
+-- 
+2.7.4
+
index e892df75a0861c15c8f3fd99f243d703a778794b..cd8897ceb511e52fd0e11b2280e361ae38cc0c55 100644 (file)
@@ -16,6 +16,8 @@ RYGEL_DEPENDENCIES = \
        libmediaart \
        sqlite
 RYGEL_INSTALL_STAGING = YES
+# We're patching configure.ac
+RYGEL_AUTORECONF = YES
 
 RYGEL_CONF_OPTS += \
        --disable-apidocs \